1

I just got my Mac several months ago, and set my right-command as show desktop shortcut. Now, I want to remove it, but I totally forget how to remove this silly thing. I have checked several places as shown in the images below, but both shows that show desktop shortcut is F11, and I don't know where else should I find the configuration where I set my right-command as the show desktop, so could anyone help me?

PS: I use OS X Lion 10.7.2

enter image description here

enter image description here

4
  • 1
    You want to see a cool trick? Press ⌘ Command + ⇧ Shift + 4 (use the 4 on the number row, you cannot use the number pad if you have one). Your cursor will change to a crosshair. Press the spacebar and it turns into a camera. Hover over the window, and click. Now, look for a 'Screen Shot PNG' file on your desktop. You're welcome :). Feb 7, 2012 at 17:37
  • @Jason: out of topic and I already used that to make this post...
    – zfm
    Feb 7, 2012 at 17:38
  • No, you didn't use that, at least not all of it. The fact that your screenshots (1) don't preserve the rounded windows edges and (2) have other window data underneath the system preferences window means that you did not do what I suggested. I was merely making a suggestion about an easier way of cutting making amazingly clean screenshots. It's not 'off topic'. Feb 7, 2012 at 17:45
  • 1
    okay I didn't use the spacebar... I would still say that it's totally OOT
    – zfm
    Feb 8, 2012 at 8:56

3 Answers 3

3

For those who like me didn't find the right answer ;-). I accidentially turned on "Show desktop" on left "Command" key. It has nothing to do with "Keyboard shortcuts" preference!

Go to "Preferences" -> "Mission Control" and change "Show Desktop" key from listbox to something useful.

Remember even if it doesn't show "left Command" key it uses it ;-), so change it.

2
  • after checking several times, this does work for me... weird
    – zfm
    May 5, 2015 at 4:37
  • You are a lifesaver. This was bugging me for the day.
    – djames
    Feb 23 at 6:29
1

System Preferences does not allow you to assign the 'meta' keys by themselves (command, option, shift, control) to take some sort of action, I believe you installed some sort of third party program to set this up.

The first one that I could think of would probably be KeyRemap4MacBook, but there are many other apps that it could be.

I would suggest that you review the icons located in your menu bar, and see if any of them have to do with keyboard customization.

Various icons in the menu bar

4
  • Off topic: icons are for Skype, Cyberduck, don't know, don't know, Divvy, Wifi Bluetooth, Sound
    – Stu Wilson
    Feb 7, 2012 at 18:18
  • Skype, Adium, Alfred, SMART Reporter, Divvy, WiFi, Bluetooth, Sound, Time and Date, Fast User Switching, Spotlight Feb 7, 2012 at 18:28
  • 1
    @StuWilson You picked the wrong duck :). Feb 7, 2012 at 18:28
  • there's no such a software in my mac... this thing confuses me...
    – zfm
    Feb 8, 2012 at 8:55
0

Answer from Maciej fixed it for me (can't comment or vote because I'm too new). 'Show Desktop' in Mission Control was set to F11, but left command still showed desktop. Set show desktop to left command, tested, then back to F11, and tested again.

All fixed, left command is back to normal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .