0

I purchased a 2020 13in MacBook Pro about a week ago, and today I tried installing Windows using Boot Camp for school related reasons. While trying to install it, I got an error in Boot Camp Assistant saying that my disk could not be partitioned. I tried many things, and I am still having the problem. This is all I tried:

  • Rebooted my Mac in macOS Recovery (⌘+R), and ran First Aid on all my Volumes, Container, and Disk. First Aid and Disk Utility in macOS Recovery did not give any error. I then rebooted to normal macOS and tried again to run Boot Camp Assistant, and I had the same problem. I then researched more about the problem, and I found a solution that seemed to work for many people. It said to reboot using Single-User mode (⌘+S), but my computer has the T2 Chip, so I then rebooted my computer with macOS Recovery (⌘+R) again, made sure the Macintosh HD volume was mounted, opened Terminal in macOS Recovery, and ran /sbin/fsck -fy. I got an error that said "Error: Container /dev/rdisk1 is mounted".

  • I then rebooted into regular macOS and ran sudo fsck_apfs -n -l /dev/rdisk1. The output showed that there are 3 snapshots, and after the first one it showed this warning: warning: snapshot fsroot tree corruptions are not repaired; they'll go away once the snapshot is deleted. However, at the end, it showed that The volume /dev/rdisk1 appears to be OK.

  • To make sure the problem was because I wanted more storage than Boot Camp could allow, I tried setting the Windows size to 60GB, and it still gave me the error.

  • The Windows version I am trying to download is the Windows Education Version found here: https://www.microsoft.com/en-us/software-download/vlacademicwindows10iso. I also tried to install the regular Windows 10 version to make sure it was not a problem with the education version.

I also saw the "warning: snapshot fsroot tree corruptions are not repaired; they'll go away once the snapshot is deleted" warning in the macOS Recovery Disk Utility while running First Aid on the Macintosh HD Volume. I am not using Time Machine on my computer.

I looked at many forum posts and other websites for hours, but I could not find anything that worked. I also checked that the Windows ISO checksum was the same as the one listed on the Windows download page. I also tried reinstalling the ISO just in case, but that also did not work. I have a 2TB hard drive, and I am trying to allocate 502GB of my hard drive for Boot Camp. I have 1.8TB free on my drive.

1 Answer 1

0

I was trying to install Boot Camp using macOS Big Sur. For some reason, Beta 1 installed some Snapshots on the Macintosh HD volume that prevented the disk from being partitioned. I did eventually get it working, but the solution did not come from me. Credit goes to user tomadimitrie on the Mac Rumors forums who found the solution.

  • First I booted into macOS recovery mode, and made sure that Macintosh HD was mounted in Disk Utility.
  • Then I opened Terminal from Utilities > Terminal.
  • Then I needed to find out the id of the Macintosh HD drive by using the command diskutil list, and finding the IDENTIFIER of the Volume called Macintosh HD. This ID may be different in recovery mode than the one in regular macOS, so make sure you run the command in the recovery mode terminal. The IDENTIFIER looks something like this: disk1s1.
  • Then run the command diskutil apfs listSnapshots <Macintosh HD's disk id> to list all the snapshots, all which start with com.apple.os.update-.
  • Then delete each Snapshot by using the command diskutil apfs deleteSnapshot <disk id> -uuid <snapshot uuid from the previous command>. The last one should return an insufficient permissions, but that is fine. Reboot into macOS.

Only do this at your own risk.

Again, all credit goes to user tomadimitrie on the Mac Rumors forums, and here is the original post to the solution: https://forums.macrumors.com/threads/bootcamp-not-working-deleting-com-apple-os-update-snapshots-using-tmutil.2243872/post-28654311

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .