0

I have posted something like this before, I run a 2012 MBP with Catalina. The odd behavior is that if I close the lid the machine seems to shut down completely (even with the power connected) and reboots. Sometimes it does a kind of "double reboot" where I hear the chime twice. I tried resetting the SMC, which seems to solve stuff for a while, and there is an update notice from Apple that says it is introducing battery health management among other things, so maybe that will do it.

Below is the report I got from my machine, but I have very little idea of what any of it means. So if anyone can tell me what the problem it is showing me is that would be great. Last time someone said I probably need to take this in for service and that's fine; I'll back it up again (there's not THAT much on it from the last couple of months) and if I have to, use my pre-upgrade-to-Catalina backup. FYI the only hardware work I have done on this machine is to replace the battery,hard drive and hard drive cable. The latter is notorious for failing in some mac models but in this case I don't think it's related.

Sleep Wake failure in EFI

Failure code:: 0xffffffff 0x0000001f

Please IGNORE the below stackshot

================================================================
Date/Time:        2020-07-09 22:23:24 -0400
OS Version:       ??? ??? (Build ???)
Architecture:     x86_64
Report Version:   29

Data Source:      Stackshots
Shared Cache:     0x640b000 F04A453C-3C9D-3D12-B86E-C514F0DE0B14

Event:            Sleep Wake Failure
Duration:         0.00s
Steps:            1

Time Awake Since Boot: 11s



Process:          swd [368]
Architecture:     x86_64
Footprint:        404 KB
Start time:       2020-07-09 22:23:24 -0400
End time:         2020-07-09 22:23:24 -0400
Num samples:      1 (1)

  Thread 0x810    1 sample (1)    priority 4 (base 4)
  <thread QoS background (requested background), thread darwinbg, process darwinbg, IO tier 2>
  1  start + 1 (libdyld.dylib + 109769) [0x7fff6d63bcc9] 1
    1  ??? [0x10eaba454] 1
      1  ??? [0x10eaba1dd] 1
        1  __stack_snapshot_with_config + 10 (libsystem_kernel.dylib + 135862) [0x7fff6d79d2b6] 1
         *1  ??? [0xffffff80002c8206] 1
           *1  ??? [0xffffff80009875f7] 1
             *1  ??? [0xffffff80008a0001] 1
               *1  ??? [0xffffff80002eb9e7] (running) 1

  Binary Images:
        0x7fff6d621000 -     0x7fff6d657fff  libdyld.dylib (750.5)               <D2A07EF5-A64B-3692-BE13-89DAA2EC5E80>  /usr/lib/system/libdyld.dylib
        0x7fff6d77c000 -     0x7fff6d7a8fff  libsystem_kernel.dylib (6153.101.6) <E76440E1-D1E8-3D9A-8B47-D01F554FF1C4>  /usr/lib/system/libsystem_kernel.dylib
Model: MacBookPro9,2, BootROM 231.0.0.0.0, 2 processors, Dual-Core Intel Core i5, 2.5 GHz, 8 GB, SMC 2.2f44
Graphics: kHW_IntelHD4000Item, Intel HD Graphics 4000, spdisplays_builtin
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x802C, 0x384B54463531323634485A2D314736453220
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x802C, 0x384B54463531323634485A2D314736453220
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (7.21.190.33 AirPortDriverBrcm4360-1601.1)
Bluetooth: Version 7.0.4f6, 3 services, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: WDC  WDS100T2B0A-00SM50, 1 TB
Serial ATA Device: HL-DT-ST DVDRW  GS41N
USB Device: USB 3.0 Bus
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: IR Receiver
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: FaceTime HD Camera (Built-in)
Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1

,,,,

  • I would start with deleteing the sleep image so it's forced to create a new one. Delete /var/vm/sleepimage. If that doesn't solve it, try installing a clean version of macOS on an external drive and boot from there. See if the problem persists. Also, was this an in-place upgrade or a clean install of Catalina? – Allan Jul 10 at 18:01
  • @Allan - i had upgraded from Sierra to Catalina - not a clean install. Um, how do I delete that file? Like, what folder is it in? I tried searching for it and came up empty... – Jesse Jul 10 at 20:16
  • I gave you the whole file. If you want to confirm it, type pmset -g it will tell you the location of the sleep image file. I'm not a fan of in-place upgrades because you get remnants of the old with the new and they don't always place nice. This is why I recommend doing a clean install. But before wiping your internal drive, install it to an external drive to be sure it fixes it. – Allan Jul 10 at 20:58
  • Are you talking about commands in Terminal? and when you say you gave me the whole file I am not sure what that means, you mean the filename? Does /var/ represent the folder? When i plugged in sleepimage to he command-F it came up empty. You have to understand, Terminal commands are something I have only ever used very occasionally; I know zero about 99.999% of it – Jesse Jul 10 at 21:44
  • Sorry...I thought you knew how to enter commands in Terminal. Yes, var represents the folder. Open Terminal, type pmset -g. Down the output, you will see a line that says “sleep image”. To delete that file, type sudo rm /whatever/that/line/says. You’ll have to enter your password. – Allan Jul 10 at 21:49

You must log in to answer this question.

Browse other questions tagged .