2

After upgrading to Catalina, when I write a lot of data inside a Linux VM (Ubuntu 20.04) by running dd if=/dev/zero of=zero, after writing a couple of gigabytes the macOS host hard-freezes (mouse cursor doesn't move). After 100 seconds, the system restarts ("Your computer was restarted because of a problem"). Since it is the host that freezes, I'm assuming this is a problem with VMware Fusion, macOS, or my hardware, rather than the guest OS.

The diagnostics produced by the "Report" button after restarting just show a watchdog timeout:

panic(cpu 2 caller 0xffffff7f84e56a8d): watchdog timeout: no checkins from watchdogd in 99 seconds (81 total checkins since monitoring last enabled)
Backtrace (CPU 2), Frame : Return Address
0xffffff81e26c3c40 : 0xffffff8003d1f5cd 
0xffffff81e26c3c90 : 0xffffff8003e58b05 
0xffffff81e26c3cd0 : 0xffffff8003e4a68e 
0xffffff81e26c3d20 : 0xffffff8003cc5a40 
0xffffff81e26c3d40 : 0xffffff8003d1ec97 
0xffffff81e26c3e40 : 0xffffff8003d1f087 
0xffffff81e26c3e90 : 0xffffff80044c2838 
0xffffff81e26c3f00 : 0xffffff7f84e56a8d 
0xffffff81e26c3f10 : 0xffffff7f84e5647b 
0xffffff81e26c3f50 : 0xffffff7f84e6bd9c 
0xffffff81e26c3fa0 : 0xffffff8003cc513e 
      Kernel Extensions in backtrace:
         com.apple.driver.watchdog(1.0)[B435C72B-B311-3C67-8AA1-1D5CE0FAD429]@0xffffff7f84e55000->0xffffff7f84e5dfff
         com.apple.driver.AppleSMC(3.1.9)[4589419D-7CCC-39A9-9E2F-F73FE42DD902]@0xffffff7f84e5e000->0xffffff7f84e7cfff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[0A7D7382-66FE-391B-9F93-97A996256C25]@0xffffff7f84e4c000
            dependency: com.apple.driver.watchdog(1)[B435C72B-B311-3C67-8AA1-1D5CE0FAD429]@0xffffff7f84e55000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[BE052F4D-9B80-3FCD-B36D-BACB7DEE0DF2]@0xffffff7f84731000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
19F101

Kernel version:
Darwin Kernel Version 19.5.0: Tue May 26 20:41:44 PDT 2020; root:xnu-6153.121.2~2/RELEASE_X86_64
Kernel UUID: 54F1A78D-6F41-32BD-BFED-4381F9F6E2EF
Kernel slide:     0x0000000003a00000
Kernel text base: 0xffffff8003c00000
__HIB  text base: 0xffffff8003b00000
System model name: MacBookPro13,2 (Mac-66E35819EE2D0D05)
System shutdown begun: NO
Panic diags file available: YES (0x0)

I tried running First Aid in Disk Utility, and cp -r'ing the VM in case it's a file system issue, but it hasn't helped.

What can I do to further debug the problem?

6
  • Could you add the following information to your question (it may help troubleshoot the issue)? 1) VMware Fusion version 2) Catalina version. – jaume Jul 10 '20 at 8:47
  • 1
    It's the latest version for both: VMware Fusion 11.5.5, Catalina 10.15.5 (19F101) – Jo Liss Jul 10 '20 at 12:56
  • Thank you, are VMware Tools installed? (You can either install VMware Tools from Virtual Machine > Install VMware Tools or open-vm-tools from Ubuntu, see kb.vmware.com/s/article/1022525 and websiteforstudents.com/…, respectively.) – jaume Jul 10 '20 at 13:08
  • 1
    Yup, open-vm-tools is installed and up-to-date. (I don't assume the problem is inside the guest anyway, since guest problems shouldn't be able to crash the host.) – Jo Liss Jul 10 '20 at 15:00
  • What does activity monitor show especially on memory. My first guess us that the machine is swapping heavily – mmmmmm Jul 10 '20 at 19:06
2

I never figured out how to debug this properly, but the following seems to have fixed it:

  1. Run fsck (xfs_repair) on the VM filesystems. (I'm not sure whether this was really necessary; the crashing still kept happening until I did step 2. I'm just reporting it for completeness.)
  2. In VMware Fusion, go to Virtual Machine -> Settings -> Advanced, and set "Hard disk buffering" to Disabled.
1
  • Thanks! I was hitting this crash / kernel panic every time I tried to restore a MSSQL db. Doing step 2 resolved it for me. – philcruz Dec 29 '20 at 23:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .