1

I can open a new window from the menu bar, but for some reason Safari insists on opening a new tab rather than a new window when using either the default keyboard shortcut or a custom shortcut.

Has anyone run into this issue before? If so, how did you fix it?

Note: I have quit the application multiple times and restarted the computer.

1
  • You're not running the developer beta are you? Some stuff related to this behaviour has changed. Jul 9, 2020 at 4:19

2 Answers 2

4

SOLUTION:

"There is a setting in System Preferences > Dock called "Prefer tabs when opening documents". Change this to "Manually"..." (Solution via Stack exchange)

2
  • No worries at all, and welcome to stack overflow. :) Jul 20, 2020 at 6:21
  • This option has been moved to General > Prefer tabs, then select "never". It will automatically update your Safari shortcut to ⌘ N instead of ⌥⌘ N Sep 24, 2022 at 17:30
1

In full screen mode, Cmd-N opens a new Tab instead of a new Window. Are you in full screen mode?

Also, in System Preferences > Keyboard > Shortcuts you can adjust the Cmd-N shortcut to open a new tab.

And it wouldn't surprise me if there is a hidden defaults write command to do the same, though I wouldn't know off the top of my head.

4
  • 1
    Definitely not in fullscreen mode, tried both the default keyboard shortcut and a custom keyboard shortcut, and I am running an up-to-date version of Catalina (made sure there wasn't an update before I posted the question).It was working just fine until today.
    – Cabana0309
    Jul 9, 2020 at 4:21
  • @Cabana0309 do you have any extensions? Jul 9, 2020 at 4:33
  • I do, but even with them disabled and starting my computer in Safe Mode the issue persists.
    – Cabana0309
    Jul 9, 2020 at 11:22
  • Figured it out! Posting the answer now.
    – Cabana0309
    Jul 9, 2020 at 11:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .