0

I've installed Big Sur beta 2 and tried to use Boot Camp Assistant but I got the error "disk could not be partitioned". Also tried to partition manually but "a problem occurred while resizing APFS container structures". I don't use Time Machine but there were 3 snapshots starting with com.apple.os.update- that can't be deleted. I ran First Aid and fsck_apfs and no problem was found. Any other thing to try? Thanks!

  • Note that since Big Sur is a developer only beta you WILL have problems with it that you are expected to not share with the world at large (read the NDA you signed to be able to download Apple beta software). the best way to handle these is to file an official bug report. – Steve Chambers Jul 8 at 20:47
1

Finally found a fix! Deleting snapshots using tmutil didn't work but I deleted them with diskutil from Recovery: diskutil apfs listSnapshots <Macintosh HD's disk id> and then diskutil apfs deleteSnapshot <disk id> -uuid <snapshot uuid from the previous command> for every snapshot. I had 3, two of them were deleted and one returned "insufficient privileges" but it doesn't matter, now everything works. Do it at your own risk, I don't know whether it will work on your Mac.

| improve this answer | |
  • 1
    This worked for me as well. – Dave Jul 14 at 2:09
  • 1
    Glad it helped :) – Toma Jul 14 at 8:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .