6

I have three early 2013 macbook pro logic boards, one will load apple AHT (apple hardware test), the other two produce the following error booting into diagnostics:

Error: 8000000000000003, Cannot load 'EFI/Drivers/TestSupport.efi'

Status: 0x00000003

Using all the same parts except the logic boards swapped confirms the issue is based solely within the logic board itself.

I have tried using the github AHT for this model by both moving it into the .diagnostics folder and creating USB media, both produce the same error.

After days of research with little solid info, I have seen anecdotal accounts that:

  • this was caused by apple with an os based update that also updated the efi firmware and broke AHT at some point,
  • some people have successfully downgraded or restored the firmware to fix their issue on other models, but cannot find any information on how to do this on this model, or where to even get the old firmware to do this with.

Does anyone know how to get the efi based AHT to work again when they encounter this error? Apple store refuses to help with this issue.

1 Answer 1

3

Apparently, it is Apple themselves who broke this. They seem to do not care about owners of older machines. I read about this on various sites. Here is one of them:

https://eshop.macsales.com/Service/Knowledgebase/Article/26/780/macOS-1014-Disables-AHT-Apple-Diagnostics-on-Select-Macs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .