0

Finder does not recognize all sharepoints available, opens only 1 that was previously mouned by default;

runing macOS Catalina 10.15.5 acting as client connecting to AFP File Server running Mac OS Server Sierra 10.12.6)

On my server (Mac OS Server Sierra 10.12.6) my sharepoints look like this:

enter image description here

I should have 4 available sharepoints (shared folders) to my user jfb on the system: FAMILY-ARCHIVE, jfb, PHOTOS-ARCHIVE, and VAULT (the other two you see in the picture are not accessible by my user jfb)

However, when connecting to this server from a machine running macOS Catalina 10.15.5 (*intermitant), my client machine bypasses the sharepoint selection screen and goes directly to mount a single sharepoint that I previously have mounted

This happens even though I DO NOT have the username/password stored in teh keychain-- I just connected to this sharepoint earlier in this finder session with it.

enter image description here

If I disconnect the sharepoint (using the "Eject" next to the sharepoint in any finder window) and reconnect, the same thing happens.

*Please note that this worked several times before and I have seen this symptom be intermittant.

2 Answers 2

0

This is a disappointing answer for Apple, but if I restart my mac, the Finder apperas to reset and then prompt for my un/pw on the next connection attempt:

enter image description here

enter image description here

2
  • Update 2020-07-13 -- today restarting my mac did not work. as well, I deleted the item in the keychain, tried to connected again and noticed that the keychain ITEM MYSTERIOUSLY RE-APPEARS after being deleted. I deleted it multiple times, then finally restarted, and finally, the Finder presented me with the full connect dialog which is the ONLY way to fix the symptom. Once finder hangs onto sharepoints it has connected to previously, it hangs onto them feriouscly. .
    – Jason FB
    Commented Jul 13, 2020 at 23:26
  • What’s your plan for now that server.app isn’t getting updates? I’m assuming you just scripted the client to connect to each mount sequentially since finder managing the credentials was off for your setup (I couldn’t reproduce your situation on our old server)
    – bmike
    Commented May 20, 2022 at 10:25
0

I would suggest the following:

  • Turn off all iCloud logins, iTunes account activity on every machine.

  • Confirm on the user login machine that the user account short name is correctly showing up as a user with the correct privileges in the server admin

  • Visit Utilities → Keychain and confirm your keys and intermediates and self root are 'trusted' (ie. Blue) not brown or 'system defaults'

  • Choose the logins tab and confirm you have only ONE login password listing for the authorized user account to the server sharepoints.

On the 'Server'

  • Confirm that it is on a fixed IP address. If you only have Mac computers, you can use the Network Setting for your Ethernet connection as 'DHCP with Manual IP'.

  • You do have Airport/WiFi turned disabled on the 'server', yes?

Last is Utilities - Keychain

  • Check no doubles for Login list of Passwords
  • No Share login from the Server to ANY user account machines
  • Root Certificates are valid and Trusted.
  • No Apple certificates are listed as Expired, or multiple Expired and Valid Certificates.

If this has all been accomplished, then next is throwing out the WiFi/network device, or installing a router in front of the network to issue DHCP for both wired and WiFi devices.

1
  • I will check this later in more detail. The server & client are on the same local network, the server has a 'fixed' IP (set via router which does this conveniently). The two machines can see each other OK.
    – Jason FB
    Commented Sep 30, 2020 at 15:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .