A MacBook Air with a SSD, the boot drive, name consisting of 220 double-quote characters.

MBA 2014 with Sierra 10.12.6 (not high sierra)

These did not work:

  • From a finder window, R-click in name column Dialog popup - "The name can't be used. Try using a name with fewer characters, or with no punctuation marks"
  • From finder window, sidebar - just to be exhaustive, same result
  • From the Info dialog.
  • From the terminal.
    • At the user home directory: diskutil rename /Volumes/oldname new name . I get the message "could not find disk for /Volumes". I tried using single-quotes around oldname, but same result

1 Answer 1


diskutil rename lets you specify the original location in ways other than by name.

I think some variation on this will work for you: diskutil rename disk1s1 "NewHDDName2"

Running diskutil list first should let you figure out the identifier for the volume.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .