0

I recently bought a 2TB SSD hard drive, placed it in a USB 3.1 enclosure and formatted it to Mac OS Extended (Encrypted). I began to do a straight copy from another SSD (Sata), both connected via USB-C, the transfer was working fine, then froze. I cancelled the transfer, and the finder bar froze on "stopping". It was frozen for a while and eventually the entire Mac crashed.

After a restart, the new SSD (NVMe) would not appear, not in Disk Utility, Terminal or System Information. All that would appear in System Information was the enclosure with the name "JMS583". The SATA drive worked as normal. I physically reset the drive in it's enclosure, and it had no effect. Eventually I connected it to my old Macbook Pro 13" via USB-C to USB-A and it appeared. I re-formatted it and successfully copied everything across.

However, the drive still refuses to appear on my new laptop over USB-C, it only appears when connected to a USB-A port on my HyperDriveNet (which then converts to USB-C). If I connect to a USB-C port on the HyperDriveNet (USB-C to USB-C) it does not appear.

I've tried repairing via terminal over USB-A and it's had no effect. I've seen similar posts here and here. But nothing has helped. I unfortunately have no access to another USB-C laptop to check whether it's my laptop (I would not be surpised, Catalina and the MacbookPro 16" have been a real disappointment) and I would rather see if it can be solved without buying an additional enclosure/drive.

What I have gathered from my attempts is that...

• The SSD, enclosure and format will work with my mac, as seen over USB-A.
• The mac is detecting the enclosure over USB-C, just not the actual storage ("JMS583")
• The drive as a whole has worked before over USB-C as seen on the first attempt that led to a crash.

Could something have happened in that crash that meant it will no longer be seen over USB-C. I've pre-ordered an OWC thunderbolt enclosure... But waiting till August is not really an option.

Any help much appreciated!

Thanks

  • It's possible that the SSD or the enclosure was bad, and copying files triggered it. Have you tried plugging the NVMe drive into a different enclosure or computer? – At0mic Jul 6 at 13:55
  • Unfortunately not as I don't have one handy, if I can't get a software-based fix I may have to order another and try that. – ConsHugs Jul 6 at 13:58
  • You might have better luck with a USB-SATA adapter - at least they're typically less expensive than the full enclosures. I've used an adapter made by StarTech, and found it to be reliable. This one is USB 3, they also make them for USB-C – Seamus Jul 7 at 3:28
2

I had the same issue. You need an NVME enclosure that has the ASM2362 chipset and not the Jmicron JMS583 chipset. All NVmE enclosure with that chipset have compatibility issues on the Macbook Pro 16 only and maybe the newer Macbook Pro 13. My older Macbook pro has no issues. Ugreen NVME enclosure on Amazon has the ASM2362 chipset which work well on the Macbook pro 16. Hopefully Apple fixes it or Jmicron comes out with a patch. Same issue with Big Sur as well.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .