I have WD External SSD Drive and macOS Catalina. The drive is formatted in ExFAT

Initially, I used my external drive 2-3 times and it was working fine. Suddenly today I am not able to write anything in my Drive as its showing Read-Only.

output from mount

/dev/disk2s2 on /Volumes/MUKESH (exfat, local, nodev, nosuid, read-only, noowners)

I have tried running following command but it did not work.

sudo chmod -R 777 /Volumes/MUKESH

Here is what I see in disk utility enter image description here

In Get-Info section I see this.

enter image description here

  • Can you drop down the Sharing and Permissions and add yourself back in as R/W? IT could also be objecting to being pulled rather than eject - check disk utility and run repair on it. – user370793 Jul 4 '20 at 15:31
  • Did that, but still, it's not working. – Mukesh Yadav Jul 4 '20 at 15:39
  • Both of them or one of them? – user370793 Jul 4 '20 at 17:07
  • 1
    Is your computer a personal machine, or a centrally managed machine from an employer? There is an IT management policy that can lock out writes to external storage for security reasons – vykor Jul 4 '20 at 17:09
  • @vykor My machine is my office machine, I am not sure if the software which was installed is blocking it. How do I check it? I do not have another mac machine. – Mukesh Yadav Jul 4 '20 at 17:12

If you can, go into Disk Utility (like you are), and use First Aid on the partition in question. Depending on the size of your drive, it will take a while, but when it should restore write capability to your disk.

Source: I did the same thing when my MyBook 2TB was randomly showing up as read-only.

  • I had tried this option. But apparently, it did not work for me. – Mukesh Yadav Jul 4 '20 at 18:16
  • I think that you must assume that you have a bad drive, and immediately make a backup of it (although my experience was on Mojave, not Catalina) – Matthew Barclay Jul 4 '20 at 18:22
  • I tried it in ubuntu machine and it works there. – Mukesh Yadav Jul 4 '20 at 18:26
  • If I were you, if Ubuntu has any disk checking tools I'd use those on the drive just in case – Matthew Barclay Jul 4 '20 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .