1

I've got an iPad 2 running iOS 9.3.5 which has a touchscreen that doesn't work. I'd like to recover the pictures from it preferably without having to pay to have a screen replaced on what is essentially an unsupported paperweight at this point.

I've got a USB to 30pin adapter so I can connect a keyboard which has let me unlock the iPad. The problem now is that although it is unlocked I have to allow access/trust any computer I connect it to, which I can't do because I have to unplug the keyboard to plug in the USB cable.

My first idea was to pair it with a bluetooth keyboard. Unfortunatley iOS 9.3.5 seems to be horrificly bad at handling keyboards. Using Meta+Space I can get into settings but once in there I'm stuck. I can search within settings but can't get out of the search box and interact with the app iteself.

This issue is compounded by it not having any internet access. Again if I could navigate settings I could connect it to wifi but that wont work. Of course because its not connected to wifi siri wont work.

I'm running out of ideas at this point. We are 1 button press away for getting the pictures off but there seems to be no way to get that input into the iPad. I've even tried the old hit the back corner of the iPad trick to re-seat the digitizer connection to no avail.

I have a Windows machine and Mac that can throw things at this iPad if anyone has any ideas.

  • Have you tried with a USB hub? – Harcker Jul 2 at 11:10
  • I've not one to hand, although I'm not sure how it would work with relation to which device is the USB host as the iPad needs to host the Keyboard whilst the PC needs to host the iPad for data. – Arcath Jul 2 at 12:04
0

After a lot of other ideas the person I was doing this for was able to give me an old WiFi network that the iPad had connected to. Once I had internet access on the ipad it was "easy"

Using Siri I enabled voice over (Say "Enable Voice Over").

Then I went into bluetooth settings and switched on bluetooth whcih I did by asking siri for the bleutooth settings and then using Ctrl+Alt+Space (Ctrl+Option+Space on a mac keyboard) to switch it on. Once It saw the bluetooth keyboard I had prepared earlier I again used Ctrl+Alt+Space to pair with it.

Once I had the Bluetooth keyboard paired I connected the iPad to the computer using the cable and then used the bluetooth keyboard to Ctrl-Alt-Space the allow button and thats it. All data is being recovered now.

It is nothing short of a nightmare to navigate on an iPad with a keyboard but it is dooable.

I had already tried a digitizer replacement but it appears that the connection in the iPad was damaged as its digitizer worked on another iPad and none of the digitizers I had worked on this one. I do not belive it would have been possible to do this without getting it onto the internet.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .