1

A few days ago, my 2018 MacBook Air entered console mode after logging in:

enter image description here

and then switches back to graphical mode (full video here).

I didn't install any system updates. I didn't see anything in the system logs. Console output shows nothing relevant (AFAIK).

Also, after this issue appeared, macOS asks me to allow incoming network connections for emlog.pl.

Any idea how to debug this issue? I've already tried to reset NVRAM, PRAM and SMC.

2
  • That progress bar looks like what's shown at system startup, not at login. Are you sure that's the login screen, and not the FileVault pre-boot authentication screen (which looks very similar, but is technically completely different)? The pre-boot auth screen appears if you have FileVault encryption turned on, and shut down or restarted the computer instead of just logging off. Aug 1 '20 at 1:31
  • @GordonDavisson You are right, this is in fact the FileVault pre-boot authentication screen, not the user login screen. Aug 4 '20 at 10:52
1

It seems like you have filevault enabled. You also have verbose mode enabled. Because of this macOS needs to finish booting into the decrypted drive and it shows verbose output.
To avoid this disable filevault or verbose mode. That should fix the problem.

To disable filevault go to system preferences->security->FileVault and disable it there. If you want to disable verbose mode then I think you need to change back boot-args by running sudo nvram -d boot-args.

1
  • Yes, filevault is enabled and disabling it is not an option. Verbose mode is not enabled. Jul 27 at 10:02
1

I've never found this issue's root cause, but it was solved by wiping the disk and re-installing macOS.

This is probably a filevault-related issue but I needed to rule out the possibility of an hardware issue as my MacBook warranty was expiring. So I had to do it the hard way.

0

It looks like its going into Verbose Boot Mode.

The emlog.pl is a Perl script which invokes a logging tool.

Why this happened I can't tell you.

3
  • The strange thing is that there's no issue during system boot. Verbose mode is enabled only after I submit my password on login screen. Jul 1 '20 at 18:06
  • It happens on every login, or it only happened once? Jul 1 '20 at 19:58
  • @MarcWilson It happens on every login. Jul 2 '20 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .