0

After WWDC2020 I can't open common YouTube in Safari on my MacBookPro 2020. I'm being redirected to m.youtube.com each time which looks just like on iPad or iPhone. The main problem is that I can't watch any video "because macOS doesn't recognize internet addresses starting with rtsp:" (I see this when I start any video). What to do about it?

UPD: I have macOS Catalina 10.15.5

UPD#2: I have a default user agent and changing it to any other doesn't help.

5
  • Did you change the User Agent to "Safari - iOS 13.1.3 - iPhone" (or similar) under Development>User Agent? – jaume Jul 1 '20 at 14:20
  • 1
    @jaume I have a default user agent – Mark Tiukov Jul 2 '20 at 8:19
  • Maybe try removing the "m." part from your address bar and check if it works – Pulakesh Jul 2 '20 at 9:46
  • @Pulakesh I've tried it too, doesn't help :C (it still redirects to m.youtube.com and I can't figure out how to change it) – Mark Tiukov Jul 2 '20 at 9:47
  • Have you tried deleting caches/cookies/local storage for youtube.com, m.youtube.com, google.con, accounts.google.com etc., and then restarting Safari? – Harcker Jul 2 '20 at 11:15
0

Found the next solution: clicked on my avatar, then settings. There was the sacred button "full-version"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .