1

I have a 2018 15" MacBook Pro running OS X Catalina 10.15.5 (19F101). When I am connected to the company VPN (via the built-in client, no third party VPNs), and my computer goes to sleep, it often freezes for a few minutes when waking up.

When this happens, upon tapping a key or the track pad the screen wakes up, but the mouse cursor is frozen, and the keyboard does not seem to register any input. The touch bar still works (I can adjust volume, brightness, etc), and if I press Esc then the screen immediately turns off, as though it realized "oh snap, I'm actually still asleep". If I wait 3-5 minutes, it will eventually shake itself out of this stupor and wake up properly.

It also only seems to happen if it goes to sleep for at least a few minutes (so, only on actual sleep, not just display blanking).

edit: remove previous edit

  • seems there was a fix recently? now the VPN is disconnected/reconnected upon waking. i assume it was an update, but i cant be sure. – wellsinator Aug 25 at 5:23
0

I also have the 15” 2018 MacBook Pro running Catalina 10.15.5 and am running into the same issue.

This started a month or two ago but has gotten worse, today especially.

The keyboard and mousepad freeze after a certain amount of time after closing the lid; when I reopen it’s unresponsive. It used to work after I woke up the Touch Bar, however that’s no longer waking the keyboard and pad. I’ve just reset the SMC so will update if this manages to fix the issue.

| improve this answer | |
  • Welcome to Ask Different! This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post once you have sufficient reputation. If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – Tetsujin Jun 30 at 11:43
  • Did resetting the SMC fix the issue? (if it did, you could probably edit this into being a proper answer). – Charles Duffy Jul 5 at 1:41
  • @CharlesDuffy it did not work for me, but it seems like it was fixed recently. now the VPN is disconnected/reconnected upon waking. – wellsinator Aug 25 at 5:23
0

I have a 2019 16" MBP that's been exhibiting this issue. Tried several other fixes (updates, etc), finally reset the SMC a couple of days ago, and that appears to have resolved the issue. Will update if it returns, but based on a couple of days use, SMC reset is the ticket.

Also for anyone bumping into this, it was something about the internal keyboard and trackpad. While this issue was in effect (before the VPN would time out), plugging an external keyboard mouse worked fine, as did VNC/Screen sharing into it while being unable to use the internal keyboard/trackpad.

| improve this answer | |
0

i have 15" 2019 MacBook Pro Catalina. same issue too after reset SMC... just wait about 5 minutes. then disconnect VPN. and can use keyboard and mouse.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .