2

My problem is that my Mac starts up to the "El Capitan" installer. After restarting several times, OS X is still on screen telling me that "no packages were eligible for install".

Can someone help please, and can you bear in mind that I’m not technically minded so keep instruction in simple terms.

  • 1
    Thank you for coming back to me. My Mac is 10.8.6 from memory. I had gone into Debenhams website and got message saying unsafe and I may need to upgrade browser, giving me link to El Capitan. Tried to install, told me it couldn’t and I’ve now got XS 0 installer on screen which won’t quit despite me trying as per above. Will try screenshot in separate post. Thanks again. – Fiona Gartshore Jun 20 at 17:10
  • 1
    I have Snow Leopard. – Fiona Gartshore Jun 20 at 17:17
  • 1
    Sorry, screenshot not happening due to me being a dinosaur so I’ll describe and hope this helps - OS X To set up installation click Continue. To repair disk using Disk Utility.... I press Continue then 2 disc pics appear - MacHd oand backup - I choose Mac - tries to install - new message says no packages were eligible for install. When I power on, usual disc run sounds, screen has Apple logo, boot line goes half way, then new screen and half way again then OS X install appears again. Quit installer in top left screen doesn’t work or other recovery I’ve tried. I don’t get Machd reinstall option – Fiona Gartshore Jun 21 at 11:06
  • 1
    Many thanks again. Your lst option - computer went through same attempts as before - 2nd option - I don’t have apple keyboard so pressed Ctrl Alt R - same attempts with no window appearing - but and it’s a big but - I’ve been getting message for while that my back-up not succeeding and have no idea why, so guess that not be a good option at this time. As you suggest I will speak to Apple - many many thanks for all your efforts, especially given my tech dinosaur way of describing. Take care. – Fiona Gartshore Jun 22 at 22:26
  • 1
    Great to hear from you again - I’ve tried exactly as above but sadly no luck - just to mention when Terminal box opens -bash-3.2 hashtag is sitting there and won’t let me delete before I type your instruction. After I do that and press Enter, new line of -bash etc appears. – Fiona Gartshore Jun 24 at 9:41
4

As explained here, OS X 10.11 "El Capitan" fails to install because it is too old (the technical reason being that the signing certificate is no longer valid).

But you can trick the OS X installer into thinking that it is 2017 and it will happily run without any errors.

How to trick the OS X installer

  1. When the OS X installer complains that "No packages were eligible for install" and displays this window:

    enter image description here

    don't restart your Mac.

  2. Turn Wi-Fi off or unplug the Ethernet cord, depending on your configuration, to prevent your Mac from connecting to the Internet:

    enter image description here

  3. Select Utilities>Terminal:

    enter image description here

  4. Click the window that appears:

    enter image description here

    and type date 0115124517 (this will reset the date to Jan 1st 12:45 2017). After typing the command, press Enter:

    enter image description here

    Terminal will confirm that the date has been changed with a line of output that displays the new date.

  5. Quit Terminal:

    enter image description here

  6. In the OS X installer window, press Restart:

    enter image description here

  7. When your Mac comes back up, disable Wi-Fi and leave the Ethernet cord unplugged, as explained in step 2, and press Continue:

    enter image description here

  8. Read the software license agreement, press Agree to accept it and press Continue:

    enter image description here

  9. Select the disk on which you want to install "El Capitan" and press Continue (note that the icon and name of the disk will be different in your case) (there is usually only one option. If you have several options because the Time Machine drive is plugged in to your computer, make sure you select the correct drive and not the Time Machine drive):

    enter image description here

  10. The installation should now proceed without any errors:

    enter image description here

| improve this answer | |
  • Good day! I tried your solution just now and unfortunately when I tried to restart my laptop after changing the terminal and dates. The picture in step #7 never showed up instead it continues to install then failing just like last time. Please help!!! Thank you very much!!! ****The last OS that I was using was a lion. ***** My laptop is a MacBook Air 2012 – clefnote Aug 12 at 9:41
  • update! it finally showed up! however the same error still occured to me huhu:(((. i tehere any other thing to do? – clefnote Aug 12 at 10:00
  • @clefnote: Could you try the following? Restart your Mac and start over from step 1. Then, in step 7, disable Wi-Fi and don't plug your Ethernet cable (if you use a wired connection), as explained in step 2. In other words, follow steps 1 through 6, then redo step 2, and continue with steps 7 through 10. – jaume Aug 12 at 11:42
  • well another problem for me is that whenever I restart Step 7 never appeared again. I tried a bunch of times it still leads me directly to the installing part :( – clefnote Aug 12 at 11:59
  • update! step 7 finally showed up and I am currently trying to install it while the wifi is off. Hoping it works! – clefnote Aug 12 at 12:08
2

There are two options. Both require correct keyboard function with a command key and not a control key.

First is you reinstall the os. This should be feasible for someone not looking to get technical.

The second is there is a hardware issue, again feasible without technical training.

| improve this answer | |
  • Many thanks for your response. My keyboard is not Apple so has no command button unfortunately. – Fiona Gartshore Jun 21 at 10:52
  • On a Windows keyboard, you can use the Windows key in place of Command. But it's probably the other answer (changing the date) that will get the installer working. – mwfearnley Jul 22 at 11:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .