I use Mac OS X, iPad and iPhone.

There are occasions when I receive mails send from people who uses Outlook written in different asian languages (Japanese, Korean, Chineses etc.). I could read them OK on my Mac, but if I reply to any of them, other people would sometime receive gibberish characters. On my Mac OS X's Mail.app, I have to set each email I reply to encode in UTF-8 Unicode to make sure the receiver can read it (note: if I am compose a new email then without setting the encoding, the receiver read them ok. Only on replying their email they receive gibberish).

But on my iPhone and iPad I cannot find how to set the encoding of the email. How to solve it? That is, when I reply email with asian characters, how can I ensure they do not changed to gibberish?


I seldom use Unicode characters but, as far as I can tell, it seems the Mail.app sets the encoding based on what you're typing. So if you don't type any Unicode characters it will asume a different encoding (based on the language defined in your device).

Try to add an Unicode character to your replies as a workaround (maybe in your signature)!

  • i think the problem is that the email that I receive is NOT in unicode so when I replied automatically mail.app does not use unicode. I think mail.app is replying the email in an encoding that is set by the sender email. Mail.app on desktop can be set, but on iPhone and iPad, the mail.app does not have that option (or I can't find it).. – KMC Feb 6 '12 at 11:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .