2

Intermittent… sometimes iMovie decides to only import 4 seconds of my movie clip even though it is much longer.

enter image description here

I am dragging it out of Photos and into iMovie

enter image description here

When I QUIT & RELAUNCH iMovie, the symptom still happens (no change).

However, the only way I can see to fix this is to do a FULL REBOOT on my machine, then the same clip correctly imports into iMovie

  • actually, rebooting does not seem to fix the problem – Jason FB Jun 18 '20 at 13:48
  • 1
    If I export the clip out of iPhoto first and onto the desktop, it then seem to drag into iMovie correctly – Jason FB Jun 18 '20 at 13:48
  • Ok good, glad that works – Macintosh Fan Jul 3 '20 at 21:41
2

If you try to drag and drop a video from photos, for whatever reasons, it only takes it in as an image, and the image is displayed for only 4 seconds by default. If you would like to import into iMovie as a video, do the following steps:

  1. In photos, select your photo, click on 'File' at the top menu, and click on 'Export'. You can export the video or the unmodified original version of it. Confirm video resolution settings. Once you click on export, select a destination to export to.
  2. Once the export is complete, drag and drop from finder into iMovie.
  • 1
    Very good! ... and welcome to Stack Exchange. – Seamus Jun 19 '20 at 1:24
  • @Seamus Thanks. – Macintosh Fan Jun 19 '20 at 1:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .