0

I've got a PATA/SATA adapter which connects via USB, and if I connect PATA drives to it they show up fine, but for some reason SATA drives aren't working. If I connect the same SATA drive to my Windows box it also shows up. Does anyone know what the cause of this is, and how to fix it?

This is on an older MacBook Pro (mid 2014), running High Sierra v10.13.6.

3
  • If you connect the same drive using the same USB adapter? – Allan Jun 18 '20 at 3:51
  • It was the same drive and adapter. Worked with the WIndows box, but not with the mac laptop. Strangely, I tried a bunch of other hard disks with the adapter, and one of them worked. The other disks worked on the Windows box, and there were no messages in dmesg for those disks on the mac. I'll do a bit more experimenting tomorrow. – Luke Quinane Jun 18 '20 at 10:36
  • As a test I tried connecting the USB adapter to a Linux VM running on the Mac, but there was still no luck. So I've switched to a Linux VM on my Windows box for now. – Luke Quinane Jul 28 '20 at 12:48
1

Assuming you’re using the same USB to PATA/SATA adapter on both the Mac and the Windows there are a couple factors which could contribute to the symptoms you’re seeing:

  • the USB to SATA bridge doesn’t use the universal driver that’s included with macOS. There may be a specific Windows driver for the SATA bridge. The PATA bridge may use the standard driver, which is why it works
  • The device may be for Windows and not compatible with macOS
  • The SATA drives may be formatted using a filesystem not compatible with macOS (i.e. Linux Ext2/3/4, btrfs, etc.)

Before you decide that the drive or device is not functional, you can parse dmesg to see if the device was detected. You can also issue the command diskutil list to see the disks detected by the OS. It may not be able to read the file system, but it will be detected.

Additionally, since this is attached via USB, you can use system_profiler to view all attached devices. Just issue the command system_profiler SPUSBDataType and parse through the output, looking for your particular disk drive make, model, and size.

0

It sounds like you've tried several SATA drives using that adapter on your system? If so it's more likely the SATA controller on the adapter has some compatibility issues with that model of system.

I've had a bunch of SATA/USB adapters that were a little temperamental on various systems over the years. My go-to solution has always been to simply order another from Amazon from a different brand. It's the blessing and curse of everything being so cheap and easy to order/receive.

My recent go-to adapters that have been reasonably reliable are the UNITEK USB 3.0 to SATA converter adapter (if it needs power), and the StarTech SATA to USB adapter - either USB C or USB 3.0/3.1 version depending on the cost and what I'll need it for.

Others may have some favorites they can share as well.

I'm not a huge fan of "buy another one" mentality, but in your case I think that's probably the easiest solution, especially as the adapters are less than $25 and quick to ship.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .