3

On my Macbook Pro 13" 2020 model, WindowServer is constantly eating away 20% to 40% CPU.

Tried the usual recommendations, but none help. (reduce transparency, display scaling etc) Also tried to disable True tone for example. It happens both with a 4K display attached, or standalone on the laptop.

When I streamed the log (log stream --predicate '(process == "WindowServer")' --debug), I see tens of messages per second showing:

WindowServer: (CoreDisplay) [com.apple.CoreDisplay:default] [DEBUG] - On display 0x78c92091, surface is not detached, CoreDisplay is detached (0x00000000), DetachCode = 0

Anyone has some ideas what this is all about?

4
  • I also see the exact same log as yours. Have you found any solution?
    – xji
    Aug 10 '20 at 16:49
  • No I didn't. But lately I don't see the extremely high CPU anymore. And I didn't fix it :) macOS update perhaps?
    – Tom Deleu
    Aug 11 '20 at 8:44
  • I was suffering from the same issue on my 2014 MacBook after upgrading to Big Sur (from High Sierra, upgraded from Mavericks over the years). Don't know about the logs, though. I finally got fed up with it and decided to do a clean install, wiping everything and restoring just what I need from backup. Aside from clearing out all the cruft that accumulated on my SSD, the WindowServer issue is gone. Recommended, if you can spare the time for a clean install! Aug 11 at 11:26
  • Update: while my MacBook does feel more responsive and the battery lasts longer since the clean install, WindowServer CPU usage still jumps to 25% when just moving the mouse pointer. Based on the number of reports I've found, I believe this is a bug in Big Sur. Aug 31 at 21:52
1

There are reports of Google Chrome causing unexplained high CPU usage in WindowServer: https://chromeisbad.com. Note that Chrome doesn't even need to be running to have this effect. It's the Keystone updater that comes bundled with Chrome causing the high CPU usage.

Completely removing Chrome from your system might fix the problem:

  1. Go to your /Applications folder and drag Chrome to the Trash.
  2. In the Finder click the Go menu (at the top of the screen), then click "Go to Folder...".
  3. Type in /Library and hit enter.
    • Check the following folders: LaunchAgents, LaunchDaemons, Application Support, Caches, Preferences.
    • Delete all the Google folders, and anything else that starts with com.google... and com.google.keystone...
  4. Go to "Go to Folder..." again.
  5. Type in ~/Library and hit enter. (Note the "~")
    • Check the following folders: LaunchAgents, Application Support, Caches, Preferences.
    • Delete all the Google folders, and anything else that starts with com.google... and com.google.keystone...
  6. Empty the Trash, and restart your computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .