I'm trying to install Windows along side my Mac OS (Catalina 10.15.15). I'm using bootcamp, but it always get stuck at partitioning, telling me it can't partition the disk and check it and fix it with First Aid.

Running First Aid it was giving me some orphaned files in the dstream. I fixed it by running network recovery, unmounting the disk and analyzing them with fsck. However, now I still have errors. If I run first aid that's the output I get: https://pastebin.com/iz5nCXPN

I know this question may look like a duplicate, but I tried everything I can find online:

  • First Aid in Recovery and Single User modes
  • Network Recovery, unmount volumes and use fsck_apfs -y
  • Partition the disk manually (Disk Utility) doesn't work either
  • Recovery mode and "Reinstall MacOS" didn't fix it either
  • Running Disk Utility multiple times, as you can see from the past points, it's an entire week I'm continuosly running Disk Utility in normal and recovery mode.
  • Running tmutil listlocalsnapshots / returns nothing as I don't have local snapshots. Time Machine is disabled since 4 days and every external drive is unplugged.

I'm out of options, and I can't either find what these errors means, nor how to fix them. So maybe asking again in 2020 could help.

  • I don't know what the errors mean either, but you should try erasing and reformatting the disk, then start up in Internet recovery mode and run First Aid again. If there are still unfixable errors, I'm pretty sure it's time to replace the disk. If the errors have gone, reinstall macOS from your TM backup. Commented Jun 16, 2020 at 13:37
  • @RichardBrockbank yeah, but this is not a fix, I wanted to avoid to format everything. Anyway that's my last hope, I guess.
    – ale93p
    Commented Jun 16, 2020 at 14:46
  • Your first Aid output shows an error saying to try running First Aid on the whole APFS container instead of a volume. I guess you probably tried this, but if not...hit Cmd-2 in Disk Utility or choose Show All Devices from the View menu so you can see the container and run First Aid on it. Commented Jun 18, 2020 at 23:31

2 Answers 2


I was able to resolve this using recovery:

  • Scan the container
  • Scan the affected volume (may not be needed)
  • Shutdown
  • Reset SMC (may not be needed)
  • Start Recovery again
  • Scan the container (less mismatch errors + some overallocation errors)
  • Shutdown
  • Start Recovery again
  • Scan the container (no errors)

Some people on other forums say it might be necessary to repeat the steps a couple of times, for me it worked the first time.


I was having a similar error and did some research on it that I thought I'd share here. An important distinction is that this relates to drives formatted as APFS. Be careful about following advice you find that may be older and not specific to APFS drives.

  • Several references (recent) point to the need in APFS drives to run First Aid on the container, not the volume. This apparently needs to be done while the system is not mounted, like in recovery mode (Command R at startup). Link
  • One user says that he manually unmounts the drive prior to running First Aid, claiming that Disk Utility sometimes fails to do so. Link
  • Another user in same MacRumors discussion (with 68000 identity points) says that he not only ran First Aid 'all instances' of his Master drive, but disabled Time Machine and then used Terminal to delete all local snapshots.Link
  • This Apple Support doc discusses viewing and deleting your APFS snapshots. Link

Drive health vs data corruption

  • The issues that I've been seeing related to this appear to be mostly related to data corruption, not due to drive failure, even though the error messages seem quite ominous. That said, reformatting your drive to resolve corruption issues is not insignificant, even if you have a recent backup.
  • This post refers to smartmon tools as a free command line APFS disk monitoring/evaluation solution. Link
  • Another post refers to a free GUI-based SSD monitor called SSDReporter. Link

Ran smartctl from smartmon tools

josh@joshuas-mini ~ % smartctl -a disk3s5
smartctl 7.3 2022-02-28 r5338 [Darwin 22.5.0 arm64] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke, www.smartmontools.org

Model Number:                       APPLE SSD AP1024Q
Serial Number:                      0ba0122c40a52e0b
Firmware Version:                   874.120.
PCI Vendor/Subsystem ID:            0x106b
IEEE OUI Identifier:                0x000000
Controller ID:                      0
NVMe Version:                       <1.2
Number of Namespaces:               3
Local Time is:                      Wed Jul 26 08:06:52 2023 CDT
Firmware Updates (0x02):            1 Slot
Optional Admin Commands (0x0004):   Frmw_DL
Optional NVM Commands (0x0004):     DS_Mngmt
Maximum Data Transfer Size:         256 Pages

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +     0.00W       -        -    0  0  0  0        0       0

SMART overall-health self-assessment test result: PASSED

SMART/Health Information (NVMe Log 0x02)
Critical Warning:                   0x00
Temperature:                        33 Celsius
Available Spare:                    100%
Available Spare Threshold:          99%
Percentage Used:                    10%
Data Units Read:                    653,815,670 [334 TB]
Data Units Written:                 495,164,729 [253 TB]
Host Read Commands:                 12,687,340,931
Host Write Commands:                6,148,184,985
Controller Busy Time:               0
Power Cycles:                       225
Power On Hours:                     5,760
Unsafe Shutdowns:                   79
Media and Data Integrity Errors:    0
Error Information Log Entries:      0

Read 1 entries from Error Information Log failed: GetLogPage failed: system=0x38, sub=0x0, code=745

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .