0

I have a MacBook Pro Retina 2012 running Mojave. I was using USB ethernet on my Mac and sharing that as a WiFi to my android phone. All was stable.

Last week I had a partition error while I was resizing the disk and OS had crashed. I had to reinstall Mojave.

Now I’m trying to use the same setup. MacBook is getting internet from USB ethernet fine. I then shared the ethernet into my WiFi like last time for my Android. The Android connects to the WiFi but this time keeps saying no Internet. Mac can connect to WiFi, but cannot share internet through it. (I would guess the NAT server is not working or something like it)

I don't know how to diagnose the problem and fix it. Please suggest.

  • This is a bit confusing. “use the Ethernet Internet that Mac gets into your Android.” Is this an Android phone/tablet or something? Where is your Internet connected to? Ethernet? What IP address does does your Android get? – Allan Jun 15 at 4:41
  • Also, “The is old Mac 2012” is confusing. Which Mac is it? MacBook Pro? Is Internet working on the Mac? – Allan Jun 15 at 4:43
  • It is Macbook pro. Yes. internet is working fine. wifi or through usb ethernet. Even the internet sharing used to be fine before the OS crash. – thevikas Jun 15 at 10:50
  • Now there’s a “crash?!” Can you please take a moment to carefully document what you have and what the problem is. As it currently stands, I can’t understand what it is you’re asking. – Allan Jun 15 at 11:30
  • I shared little more intro. Thanks for helping. – thevikas Jun 15 at 11:37
0

The crash obviously damaged something and it hasn't quite been resolved yet.

First try some simple tasks such as:

  1. Go to System Preferences--> Sharing. Turn off the Internet Connection Sharing option.
  2. Now go to Network. Then create a new location by choosing edit location and then new location.
  3. Now add back in your USB Ethernet adapter interface and apply the settings. Then test your internet connectivity on your computer.
  4. Go back to Sharing and turn your internet connection sharing back on after choosing the Share from choice (USB Ethernet) and Share to choice WiFi.

Besides that, turn off your internet connection sharing, then go back to Network. Try editing your DNS settings on the USB/Ethernet connection and use the public IP addresses for CloudFlare and Google. CloudFlare is: 1.1.1.1 in addition to 1.0.0.1 Google is: 8.8.8.8 in addition to 8.8.4.4

Once you have the DNS settings entered and applied, test your internet connection on the computer one more time, then try turning the internet connection sharing feature back on.

If it still doesn't work, it may be a much more involved fix. You might have luck by going to Macintosh HD--> Library--> Preferences. Drag the SystemConfiguration folder to the trash (don't empty it as you might need it again), then reboot the computer.

Your network interfaces and bluetooth settings will probably be wiped out at that point and you can try setting things up fresh.

| improve this answer | |
0

I accidentally found the behaviour while even my android emulator was not having internet. I was using dnsmasq and having 127.0.0.1 as my first DNS server in my Mac. The result was, the NAT server of MAC was not running its own DNS for NAT (which usually should be) but just sending all those DNS servers as-is to NAT clients (emulators and even internet sharing). 127.0.0.1 is useless for NAT client and so internet does not seem to work in those devices.

After I removed that server from my Mac's USB ethernet settings, I was back online on phone (and emulator) through my mac's internet sharing.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .