0

I'm trying to install Virtualbox on Mac Catalina. It either fails or hangs and in the console I see these messages:

error   10:46:15.111917+1000    kernel  Sandbox: installd(3456) System Policy: deny(1) file-write-data /Library/Preferences/com.apple.TimeMachine.plist
fault   10:46:15.112121+1000    installd    Couldn't write values for keys (
    SuspendHelperActivityTimeStamp
) in CFPrefsPlistSource<0x7fea7d549d70> (Domain: com.apple.TimeMachine, User: kCFPreferencesAnyUser, ByHost: Yes, Container: (null), Contents Need Refresh: Yes): setting preferences outside an application's container requires user-preference-write or file-write-data sandbox access

Any ideas on how to fix whatever the issue is? I have tried rebooting, running the Virtualbox uninstaller, repeating the install, same result. My install of Catalina is up-to-date according to the system.

0

This fixed it:

sudo kextcache --clear-staging
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .