4

I type using a keyboard layout other than the standard QWERTY. This question will apply to those who type using Dvorak, Colemak, QWERTZ, or any other international or non-standard keyboard layout.

My keyboard layout (Dvorak) is different than the standard keyboard layout for my country / locale. So this question isn't simply solved by setting a default locale; I also need to specify a default keyboard layout.

When I log in to my macOS user account, my personal keyboard layout is always used. It's also selected on the Lock Screen if I ever Lock the computer.

But when I first boot my Mac after a Restart or Shut Down, the QWERTY keyboard layout is always selected.

I'm forced to hunt-and-peck my password because my keyboard layout is not set. Or, I can manually change the keyboard layout via the Input menu (which is shown, but is not the focus of this question).

How can I change the default keyboard layout used on the macOS login window / startup screen?

  • 1
  • @TomGewecke that allows me to apply a language to the Login Window, but I don't see a way to specify a keyboard layout within that language. – pkamb Jun 12 at 17:39
  • Did you try it going thru all the steps? Step one is where the desired layout is set, the rest is supposed to make it stick. Did it not work? – Tom Gewecke Jun 12 at 19:13
  • 1
    The correct solution is in this blog. TL;DR run sudo cp ~/Library/Preferences/com.apple.HIToolbox.plist /Library/Preferences/ to copy your local keyboard settings over the default root settings. – jlyonsmith Jul 18 at 20:39
  • 1
    @jlyonsmith can you please add that as an Answer? – pkamb Jul 18 at 22:53
0

In Terminal, run this to copy your keyboard settings to the default settings:

sudo cp ~/Library/Preferences/com.apple.HIToolbox.plist /Library/Preferences/

via Change the default keyboard of OSX login screen permanently

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .