0

I have an iMac 2007 20", and its a second hand computer. It was running OSx Lion when I bought it, then I upgraded it to El capitan, After that, I made a big mistake of erasing the data without taking a copy of the dmg file in USB. After reset, I only have the option to boot into the recovery mode.

I tried to reinstall El capitan, but after i enter the Apple ID, I get the error 'This item is temporarily unavailable'. I tried many times to fix it, but didnt work.

I know how to create a bootable usb, but i dont have an another mac. All i have is just a normal Pc, Windows 10 running with 28 GB HDD and 2 GB Ram. I thought of running mac os in a virtual machine but didnt work. I coudnt find the right dmg or iso file.

I tried many ways but none of them worked. Later, I just saw a post on stackexchange - How do I create a Mac OS install thumb drive from InstallESD.dmg file using Windows 7? This thing could really work, but i need that installesd.dmg file.

This is my situation now, i dont know how am i supposed to fix it.

If anyone who owns a mac has installesd.dmg file, i would be glad if u share it to me. I have tried with many dmg files (once downloaded from https://support.apple.com/en-ae/HT206886), i used transmac also, but the usb is not recognizable by the mac. I tried using poweriso to burn mavericks iso file to usb (downloaded from https://isoriver.com/mac-os-x-mavericks-10-9-iso-dmg-image/), the usb got recognized, but there was a no entry symbol when booting. This same happened when i tried it in vmware on my pc.

If someone is happy to share me their installesd.dmg file (mostly preferred OSx lion - Osx El capitan), that would be great. But if it is not possible, i would like to hear some alternate solutions to fix it, but pls, i cant spend any more money on this as well i dont have any other macs. This is my situation.

Edited: I asked my dad to help me resolve this (btw i m a 15yo student, and my dad bought it for my study purpose), he took me to one of his frnds house who owns the same iMac which i have. He had El Cap installed on it. I downloaded a El cap dmg file from https://support.apple.com/en-ae/HT201372, and did all the instructions given on that site. Everything went smoothly. I finally created the bootable usb and booted it, and I see the apple logo and it was loading. Just in the middle of loading, i got prohibited symbol (no entry sign). I have no idea about this and idk what to do now. I still have the bootable usb with me. Is there any ways that i could successfully install Osx from that usb, by doing some repairs? and i m sure, i wont get access to my dad's frnd's iMac again. So kindly help me solve this problem. Also, i just opened that usb file from transmac and browsed through it,, and i found that installesd.dmg file and copied it to my windows pc. kindly tell me if that thing could help me in any way..

I need to join my zoom classes and i dont have a good pc, so i need to repair this thing quickly. Kindly help me. Thanks!!

You must log in to answer this question.

Browse other questions tagged .