0

I have a Macbook Pro 2015 (running MACOS 10.15.5 Cataline) and I recently bought a lavalier microphone that worked for a while. Now, all of sudden my MBP won't recognize it as an input device. This microphone has a TRRS plug.

When I plug it in, the MIDI Sound menu switches the "build in output" icon from a speaker to a headphone.

The microphone is working, I can use it on my cell phone, I can record audio on a Windows computer.

I tried this answer here but it didn't work.

Sometimes when I'm lucky my MBP does recognize it properly and recording works fine (and it used to work for a while).

Is there a way to force the plug to a certain pinout, instead of relying on the autodetection?

The microphone came with an adapter to a regular TRS 3.5 mm plug. Using the adapter makes no difference.

Thank you.

3
  • this question is three years old and doesn't have a answer. The best solution seems to be to ditch the Mac and get a decent computer, preferably running Linux. – Leonardo Jun 8 '20 at 0:56
  • The input jack doesn’t change pinouts. More than likely it’s dirty causing a faulty connection. That headphone jack is of poor quality (IMO). Get a high quality DAC – Allan Jun 8 '20 at 1:39
  • That is not so simple, as the supply voltages aren't the same and the lavalier mic needs an adapter to work with 48 V phantom power. – Leonardo Jun 11 '20 at 19:54

You must log in to answer this question.

Browse other questions tagged .