1

On a MacBook Pro running macOS Catalina Version 10.15.5, every time I try to open Mail.app in one of our user's acounts, the application fails to open and I get this error:

Mail quit unexpectedly.

Click Reopen to open the application again. Click Report to see more detailed information and send a report to Apple.

Here's an excerpt from the report:

Process:               Mail [6567]
Path:                  /System/Applications/Mail.app/Contents/MacOS/Mail
Identifier:            com.apple.mail
Version:               13.4 (3608.80.23.2.2)
Build Info:            Mail-3608080023002002~43
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Mail [6567]
User ID:               501

Date/Time:             2020-06-07 14:21:25.799 -0500
OS Version:            Mac OS X 10.15.5 (19F101)
Report Version:        12
Bridge OS Version:     4.5 (17P5300)
Anonymous UUID:        8BA95E6B-F4C0-FE35-590C-A4B6D79839C8

Sleep/Wake UUID:       560A8417-0826-4C98-BA6E-B997106BA321

Time Awake Since Boot: 56000 seconds
Time Since Wake:       1700 seconds

System Integrity Protection: enabled

Crashed Thread:        4  -[MFPersistenceVersionUpgrader run]  Dispatch queue: NSOperationQueue 0x7fe445c11cb0 (QOS: UNSPECIFIED)

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
dyld3 mode
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'V3->V4 migrator must be run before persistence version can be migrated to V5'
terminating with uncaught exception of type NSException
abort() called

Here's what I've tried so far:

  • Restarted the computer… repeatedly.
  • Tried opening Mail.app in the affected user after a Safe Boot.
  • Reset the PRAM.
  • Freshly installed macOS.
  • Confirmed that Mail.app is in the Applications folder and tried to open it directly from there.
  • Deleted all accounts from System Preferences (can't open Mail, so can't delete from in there).

All of the above has had precisely zero change on the behavior.

I created a new user on the same machine and Mail.app opens just fine on that user, so that would seem to point to an issue specific to this user, but I'm at a loss as to what that might be.

Any idea how to resolve this?

1

When I was 99% drafting the question above, I came upon a solution adapted from this post on AppleToolBox.

Here are the steps:

  1. Go to ~/Library/Containers/com.apple.mail/Data/Library/Saved Application State and delete com.apple.mail.savedState.
  2. Go to ~/Library/Containers and drag com.apple.mail and com.apple.MailServiceAgent to your desktop.
  3. Go to ~/Library/Mail/ and drag everything in that folder to your desktop.
  4. Restart.
  5. If it's now working, trash everything on your desktop.

Because I had already tried deleting accounts before finding this solution, I had to re-add all of them to the user, but it otherwise seems to be working normally again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .