I'm trying to learn to build services on my iMac running High Sierra. I open system preferences and then I click on Keyboard. From there I click on the Shortcuts tab. I get the window shown below.

enter image description here

From this pane, I click on Services on the left and check the box "Archive as tbz" on the right. I then give the shortcut control-command-a as the keyboard shortcut. I then close System Preferences and go to the folder with the folder I want to archive in it. I select the folder I want to archive then right-click on it. A context-menu comes up with Services at the bottom. I click on Services and see my new service at the bottom. I click on it but nothing happens. What am I doing wrong?

I've tried closing the System Preferences and going to Finder and run my service from there. No luck. After that, I tried running the service by right-clicking on the folder to archive. No luck. I looked up in Google "how to make a service mac" but no luck. Their method didn't work. Now I'm out of options. I also tried using the key shortcut but that didn't work either. I tried doing the same but used zip instead of tbz but zip didn't work either. Can somebody help me make a keyboard shortcut or a service?

  • Where did Archive as tbz come from, did you make an Automator Service or does that service belong to another application? If you created an Automator Service, then you should include it in your question. Otherwise, without additional information, this really can't be troubleshot well based solely on what you've provided thus far. Jun 7, 2020 at 19:52
  • it appeared under the Services listed. See my image above. It was already there, i didn't make it.
    – Natsfan
    Jun 7, 2020 at 20:23
  • @user3439894 - what else do I need to include to get an answer? thanks.
    – Natsfan
    Jun 7, 2020 at 20:26
  • If you didn't make it the where did it come from? It's not an OS default. Is it located in ~/Library/Services? Jun 7, 2020 at 20:26
  • it just showed up. i don't know how to use Automator.
    – Natsfan
    Jun 7, 2020 at 20:27

1 Answer 1


The following services are installed by Entropy:

  • Archive as 7z
  • Archive as rar
  • Archive as tbz
  • Archive as tgz
  • Archive as zip

Setting ⇧⌃⌘A on the Archive as tgz service does create a .tgz file in Finder; however, I first had to trigger it from the Services menu in Finder before the keyboard shortcut worked. This is also where I found the Entropy icon on these services.

Note: I had to add to ⌃⌘A because in macOS Catalina ⌃⌘A is: Make Alias

I also did not have these services on a clean built macOS Catalina system until after installing Entropy, without even running it first, these services appeared in: System Preferences > Keyboard > Shortcuts > Services

  • Thanks for finding out that info. It still doesn't explain why Ican't create a .tgz file. I first tried it i Finder/Services then I tried the keyboard shortcut. nothing works.
    – Natsfan
    Jun 7, 2020 at 23:42
  • @jmh, Have you tried using the Entropy app directly, and then try from Finder? maybe using the app itself will reset the services it creates. The other option is to run the following command in Terminal, which should rectify any issues with the Launch Services database: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user; killall Finder Jun 8, 2020 at 0:23
  • Entropy asks for a registration number but the app is no longer maintained so I can't use that. I'll try the system command and see if that works. Thank you very much for your help.
    – Natsfan
    Jun 8, 2020 at 0:53
  • @jmh, If it's asking for a registration number that may be why it doesn't work as its services runs the application in the background. You should probably delete the application and then run the command from my previous comment to get rid of its non-working services. Jun 8, 2020 at 1:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .