0

I have installed Dropbox app on Mac. This created a folder named "Dropbox" in my home folder.

I copied a large folder into this Dropbox folder.

The syncing of this folder is taking a lot of time so I have unlinked the Dropbox folder from Dropbox app (Dropbox app preferences -> Account -> Unlink the dropbox). Now when I try to delete this "Dropbox" folder I get the below error:

  The operation can’t be completed because some items had to be skipped. 
For each item, choose File > Get Info, make sure “Locked” is deselected, and then check the Sharing & Permissions section. 
When you are sure the items are unlocked and not designated as Read Only or No Access, try again.

I have seen the 'Get Info' and see that the folder has 'locked' checkbox not ticked and also in users I see that I have read&write access

I also restarted my Mac but I still get the same error

How do I delete this folder(including all its sub-folders). How can I force delete this folder?

I am able to move the folder to Bin but I cannot delete the folder from Bin. I was doing 'Delete immediately' option and the folder is not getting deleted. How do I get the free space on my hard drive back?

3
  • Is the Dropbox applet still running?
    – nohillside
    Jun 7, 2020 at 15:26
  • I quit the Dropbox app but did not uninstall the app Jun 7, 2020 at 15:27
  • @nohillside: I have uninstalled the Dropbox app(by moving the Dropbox app to bin) and restarted the MAC. But I am still not able to delete the "Dropbox" folder. As an admin, I want to just delete the folder from my local hard disk Jun 7, 2020 at 16:29

1 Answer 1

0

Assuming the folder is in the Trash now:

  • Open Terminal
  • cd ~/.Trash
  • rm -r Dropbox

If the folder isn't in Trash, skip the second step.

7
  • I get the message asking me override rwxrwxrwx mymacusername(firstpostcommenter)/staff uchg for somefile ? How do I give yes to all? Jun 7, 2020 at 15:29
  • @firstpostcommenter That's a bit unspecific so I hesitate to say yes without knowing what it concerns (but in general, and assuming the cd worked correctly, "yes"). If it doesn't work, please add the result of ls -le@d ~/.Trash/Dropbox.
    – nohillside
    Jun 7, 2020 at 15:31
  • drwxr-xr-x@ 3 macusername staff 96 Jun 7 17:16 Foldername com.dropbox.attrs 26 Jun 7, 2020 at 15:36
  • @firstpostcommenter Foldername is "Dropbox"?
    – nohillside
    Jun 7, 2020 at 15:37
  • I was trying to delete the large folder inside the Dropbox folder. For "Dropbox" folder when I run the given command then I get drwx------@ 4 mymacusername staff 128 Jun 7 17:14 Dropbox/ com.apple.FinderInfo 32 0: group:admin allow list,add_file,search,add_subdirectory,delete_child,readattr,writeattr,readextattr,writeextattr,readsecurity Jun 7, 2020 at 15:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .