0

WiFi on my MacBook Pro (13-inch, Mid 2010) has stopped working.

When I click the WiFi button I see the message "Wi-Fi: no hardware installed" Wi-Fi: no hardware installed

I have attempted many things, including other questions in this StackExchange site (this was the first answer I found and I followed but didn't solve my issue. Ultimately it suggests replacing my Airport card, but I'd rather eliminate all software/logic possibilities before getting to replacing the Airport adapter or buying a USB wifi adapter).

The detailed steps I've taken:

- MOVING/DELETING SystemConfiguration

I've followed this answer to check whether my en1 (airport adapter) exist and was working:

ifconfig -a - it showed up

ifconfig en1 inet up or ifconfig en1 up - both resulted in the same error: interface en1 does not exist'

Then I moved/deleted the files located at /Library/Preferences/SystemConfigurations as instructed.

  1. Removed the preferences.plist and restarted. Since it didn't resolve I continued.

  2. Removed NetworkInterfaces.plist & com.apple.airport.preferences.plist and restarted.

  3. Lastly, I attempted to remove the whole SystemConfiguration folder, but Mac didn't allow it. So I removed as many files as possible and restarted. Didn't resolve the problem, but en1 disappeared for good from System Preferences -> Network.

- NVRAM & SMC reset

Followed several guides, but ultimately this one and it didn't work. I have reset NVRAM & SMC countless times.

- AHT

Some guides suggest running Apple Hardware Test. I've tried, but it doesn't work, returns the error -3403D: as I've researched, it means AHT can't be run in my system.

QUESTIONS

Backing up and reformatting has any chance to resolve the problem? Is it worthy of trying? Any other suggestions? I'm considering to buy an USB wifi adapter.

As a last resort and hoping that my airport adapter is still working and not faulty, I'm asking here.

SYSTEM INFO

MacBook Pro (13-inch Mid 2010)

macOS High Sierra 10.13.6

NETWORK WINDOW wifi screen

  • 1
    Welcome on board. 1st thing 1st: the trick of resetting NVRAM & SMC is just a trick or a religion if you prefer. It can't fix anything about Wi-Fi problem. Just note the sources who gave you this advice to avoid them in the future. – dan Jun 5 at 21:13
  • @dan, yeah, the more I saw those advices, the more ineffective they seemed. – Rafael Vidal Jun 5 at 21:17
  • Try rebooting while holding down the "d" key to enter diagnostics mode and see what that says, or is that what you referred to as "AHT?". I doubt that it is an OS issue at this point as the card is detected by the OS. But if you have the time it wouldn't hurt to wipe and reinstall, though I am doubtful this is an OS issue. And I hate to say it but it is a 10 year old computer. The WiFi components may have just died. – Steve Chambers Jun 5 at 21:26
  • @SteveChambers: I share your analysis, this isn't an OS issue since the time 10.13.6 was produced all the quality controls have been made by the users. I think the culprit is the brave old Wi-Fi cable and its cheap socket connector. – dan Jun 5 at 21:32
  • 1
    @dan is absolutely correct about resetting NVRAM and the SMC - both are unrelated to this issue. The next myth is "reinstalling macOS." This is a major procedure and should only be done as a last resort. There's Safe Mode and Recovery Mode that basically boots a clean version of macOS - if it fails in these, reinstalling likewise will have no effect – Allan Jun 5 at 21:52

Browse other questions tagged .