0

I just erased my Macbook's hard drive (under MacOS Catalina) with touch bar from 2019.

When I turn on the computer I press cmd and R, the planet shows off and I've to select a network to connect to.

The problem is that it won't connect to any of my Wifi connexion, I tried on my initial Wifi and two repeater. I also tried to connect it to my 4G and still didn't established a connexion.

After looking into Apple's support, they suggested to test the DNS as explained here

After doing it, here is what I've got : lookupfailed

Sorry for the french but it means that the Lookup failed, it threw the same error for my LTE too.

So I'm a bit lost, I'm about to sell it but I don't know how I can fix this since my Apple Store is closed due to Covid.

Does someone have a hint about what I can do/how to proceed. I thought about booting it from a hard drive but I didn't find anything for the Macbook Pro 2019 since it has no USB port, but if it's possible I can do it since I have my work Macbook Pro available so if someone could provide me a link or anything that could help I would really appreciate.

Thanks for your help

7
  • If you can get into Terminal manually set your DNS with the command networksetup -setdnsservers Wi-Fi 8.8.8.8. That will set it to Google’s DNS server
    – Allan
    Jun 4, 2020 at 18:29
  • I unfortunately can't access to this computer terminal, does it work if I do it through an other one ? Or I should modify it from my router ?
    – StefanYYC
    Jun 4, 2020 at 18:47
  • If you can set it in your router, that would be best
    – Allan
    Jun 4, 2020 at 18:56
  • Thank you I will try that! So it's sure the problem is due to that ? I was scared for a moment
    – StefanYYC
    Jun 4, 2020 at 19:24
  • It’s definitely DNS. Normally your DHCP server (router) passes along DNS settings. The router can act as a DNS relay so the DNS server IP will be your router. Other times it will pass the DNS servers set in the router through to the client. You’ll have to verify everything in your router, but if you can set it up there, that’s the best setup
    – Allan
    Jun 4, 2020 at 19:33

2 Answers 2

1

The problem, as you’ve confirmed, is a DNS issue. What’s happening is that your Mac has no way of finding the Recovery Host to connect to.

macOS Recovery Hosts and Ports

Normally, this is taken care of in the router. What happens is one of the two scenarios:

  • The router acts as a DHCP relay. In the DHCP offer, the DNS server value is the IP address of the router. So any DNS request is sent to the router which is then sent to the actual DNS server(s) that are either automatically configured from the ISP or manually configured by you.

  • The router passes the DNS server addresses as part if the DHCP offer. Whether automatically configured from the ISP or manually configured, the client (your Mac) gets the IPs of the actual DNS server(s) and makes the request directly.

If this is not happening...

  • check your router configuration and make sure the DNS values ate being set.
  • Manually set the DNS server in macOS with the command networksetup -setdnsservers Wi-Fi 8.8.8.8 (Google’s DNS server)

If fixing DNS proves fruitless, you may need use a working Mac to create a USB Installer. This will allow you to at least install the OS without needing the Internet and then, you can use whatever work around that fixes your DNS.

0

You may take a wrong step to go. I presume that you erased disk prior to start recovery utlity first. The problem is embedded recovery utility may be erased, then it cannot start. It may try to connect to internet instead. Normally, macOS recovery utility (command + R) will use network connection previously used to connect to internet by default. You need not to setup any network connection. You may try to do option + command + R and trying to load internet recovery utility. I am not sure this will help, because you have no option to choose any networks where you can put your wifi access points and get to internet successfully. Please follow to this link; https://support.apple.com/en-us/HT201314 for better explanation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .