1

I am using a 2011 iMac as an external monitor (and speakers) for my MacBook Pro (2014) on a daily basis.

Last week, I upgraded to the 2020 MBP 13". The new MBPs with USB-C are supposed to work with Target Display Mode, using the Thunderbolt 2 to USB-C adapter. I have it connected with an official Apple Thunderbolt 2 cable and Thunderbolt 2 to USB-C adapter. But when I press Command-F2, nothing happens, like they aren't connected.

I can already rule out the cable/adapter/USB-C port being defective, because I've used for transferring files from the old MacBook to the new one successfully. It also still works fine when I connect the Thunderbolt cable (directly) to my old MBP.

Any ideas what I can do to debug the problem?

Edit: I tried it out with a colleague's MBP 2017, same cable and adapter, and it worked flawlessly. So the problem seems to be limited to the new 2020 MBP. I am in direct contact with a very helpful (and seemingly persistent) 2nd line Apple Support employee about this now, so fingers crossed.

  • What version of macOS is on the target iMac? And you’re pressing command on the iMac keyboard? – bmike Jun 6 at 1:14
  • @bmike The MacBook Pro is on Catalina (10.15.5), and the iMac is running High Sierra. – Rijk Jun 9 at 6:15
  • 1
    Hmm - High Sierra should be supported, but the iMac hardware is vintage so that makes official support hard to expect at this point. Would be nice if it kept working, but there's no expectation of support I have at this point for this. support.apple.com/en-us/HT204592 – bmike Jun 9 at 17:00
  • Yep, I understand, although the problem seems to be with the 2020 MBP rather than the iMac. All other machines are connecting just fine. I don't want to sound entitled but I really do expect this to work, and if not to be fixed. I invested a lot in all these Apple devices (now again €100 in cables and adapters), I expect them to work (and keep working) together, at least where technically possible. – Rijk Jun 10 at 18:53
2

Same issue here!

New 2020 MBP, using an apple USB-C to thunderbolt adapter, apple thunderbolt cable, mid 2011 iMac.

Apple support just informed me that they don't have this feature in newer devices. What a shame!

I'm filling out a feedback form suggesting that they bring it back. Perhaps naively hopeful that they'll respond but worth a shot.

| improve this answer | |
  • I really hope this is not the case — Apple refusing to support using two of their products together would be quite unacceptable to me. If it's the case that it's just a matter of will, we should make some noise ;) – Rijk Jun 9 at 6:06
  • The apple support person said they are also disappointed. I don't know why they got rid of it, but I send in a feedback form here apple.com/feedback/macbookpro.html – IW1234 Jun 9 at 17:30
  • 2
    Same issue with the 2020 macbook pro connecting to a 27" 2012 iMac. It was working flawlessly with the 2015 version macbook pro. 55 EUR for an adapter that doesn't work at all. I want to believe this is only a SW issue that will be fixed, I am really getting fed up with Apple lately. – Fygo Jun 9 at 17:54
0

I have the exact same problem. I spent about an hour with Apple's support team providing information. They are working on the problem, with one possibility being an issue in the latest Catalina update. I am running 10.15.4 on both my MacBook Pro (which is working) and on my wife's MBA (which isn't working). I updated the MBA to the latest Catalina version before trying Target Display Mode, so I don't know if it would have worked prior to the latest Catalina update.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .