-1

So i'm trying to erase the disk after making it to a bootable usb but now im getting this error "Couldn't open device" I've tried researching and tried every method but the usb won't erased.

I've tried first aiding it first and erase it and using other format i've tried using terminal to erase, got the same error every time.

So how can I erase /dev/disk2?

enter image description here

enter image description here diskutil list

/dev/disk0 (internal, physical):

       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *121.3 GB   disk0
       1:                        EFI EFI                     209.7 MB   disk0s1
       2:                 Apple_APFS Container disk1         121.1 GB   disk0s2

    /dev/disk1 (synthesized):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      APFS Container Scheme -                      +121.1 GB   disk1
                                     Physical Store disk0s2
       1:                APFS Volume Macintosh HD            57.9 GB    disk1s1
       2:                APFS Volume Preboot                 44.7 MB    disk1s2
       3:                APFS Volume Recovery                512.4 MB   disk1s3
       4:                APFS Volume VM                      2.1 GB     disk1s4

    /dev/disk2 (external, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                                                   *4.2 GB     disk2
  • Have you tried changing the partitions on the disk, or adding one? – jmh Jun 4 at 1:58
  • 1
    Punctuation in your write-up would have been useful. – jmh Jun 4 at 2:01
  • Please reboot to remove any potential locks a process has on the drive. If the problem persists run diskutil list and copy/paste the relevant part (describing the disk) to the question. – nohillside Jun 4 at 8:47
  • Tried rebooting and have edit my question – user13414903 Jun 5 at 4:23
0

Have you selected a partition in Disk Utility, or the entire device?

Carbon Copy Cloner has an excellent, detailed set of instructions available online. You didn't tell us which macOS version you're using (in the future, remember that will help!), but this page has instructions from Catalina all the way back to Yosemite.

Let us know if you're still having problems after trying this.

| improve this answer | |
  • Yes, I've tried everything but still it says couldn't open device. I use macOS mojave – user13414903 Jun 4 at 8:28
  • I can't imagine what could be causing this... maybe a failed disk? Is it new, used - recently? Have you tried it in another system? – Seamus Jun 4 at 8:35
  • It's new just bought it and im sure it's not broken – user13414903 Jun 5 at 6:41
0

You can start disk utility and select the disk you want to erase. Now go to Partition in Disk Utility and adjust the size or add a partition. Doing this should erase your disk. if there are no partitions add one and make it include the whole disk!

| improve this answer | |
  • I forgot to write but i've tried erasing with disk utility but still couldn't open device – user13414903 Jun 4 at 8:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .