0

Since updating to Catalina two months ago I have had this problem: My MacBook Pro HDMI output is attached to a NEC monitor. Every time I log in on my standard account the monitors are mirrored and Catalina only recognizes the MBP screen. There is no way to turn off mirroring or select the second screen-it doesn't show in system preferences, which only detects the MBP retina screen.

****About this Mac****
  Chipset Model:    Intel Iris Pro
  Type: GPU
  Bus:  Built-In
  VRAM (Dynamic, Max):  1536 MB
  Vendor:   Intel
  Device ID:    0x0d26
  Revision ID:  0x0008
  Metal:    Supported, feature set macOS GPUFamily1 v4
  Displays:
Color LCD:
  Display Type: Built-In Retina LCD
  Resolution:   2880 x 1800 Retina
  Framebuffer Depth:    24-Bit Color (ARGB8888)
  Mirror:   Off
  Online:   Yes
  Automatically Adjust Brightness:  No
  Connection Type:  Internal
**P221W:NEC Monitor ---**
  Resolution:   1680 x 1050 (Widescreen Super eXtended Graphics Array Plus)
  UI Looks like:    1680 x 1050 @ 60 Hz
  Framebuffer Depth:    24-Bit Color (ARGB8888)
  Display Serial Number:    07104621NA  
  Main Display: Yes
  Mirror:   Off
  Online:   Yes
  Rotation: Supported
  Automatically Adjust Brightness:  No

The problem didn't exist before the Catalina upgrade.

0

I don’t recommend HDMI for any sort of compute type of environment. It’s a consumer electronics video technology and very flaky (IMO). My recommendation for connecting your monitor to your MacBook is as follows:

The reason I recommend active adapters is because DVI and even the analog VGA signals have very different signaling from HDMI. Most of the time, the issue is a missing clock sync. The passive adapters can’t recreate this signal where the active ones can.

Many times, you’ll see the same setup in Windows (even on Bootcamp!) work without a problem. Windows drivers have a wider “tolerance” for these idiosyncrasies where as Apple doesn’t. The active adapters fix that problem.

1
  • Thank you for your reply. I will go ahead and purchase a DisplayPort to DVI cable. Hope this makes for a better viewing experience for the NEC screen! – 0827Phil Jun 11 '20 at 20:15
0

Besides trying the normal stuff like Resetting NVRAM and SMC, you might want to double check your Energy Saver settings and make sure "Automatic graphics switching" is enabled.

If you still have trouble, check under the About This Mac--> System Report--> Graphics/Displays. Then take a picture of that and send it over. I'm curious if your MacBook Pro is having trouble with the AMD Radeon card or the drivers that support it.

2
  • Greetings and thank you for the suggestions. I may need to try Resetting tips. My MBPro has an integral graphics card (Intel Iris Pro) rather than an AMD Radeon card. One thing that worked: unplug the HDMI to DVI from the MBPro and plugging it back in and then the second NEC screen was recognized and mirroring went away! – 0827Phil Jun 11 '20 at 20:13
  • Great news! The HDMI can be a little temperamental as there's a whole discussion that happens between the chipset, the cable, and the device connected -- so that may be your go-to solution for a bit. – wizdomonwheels Jun 11 '20 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .