0

I wanted to install GnuPG by compiling the binaries but I'm stuck on the second dependancy, libgpg-error. I'll check the obvious tomorrow and shasum the tarball, re-download it (etc) but I'm hoping I can find a little insight into what's going on here. I'm on macOS Catalina.

Here's what I'm trying to do in Terminal (as is documented in the README). Briefly, configure, make, install:

sudo ./configure
sudo make
sudo make install
sudo make clean

However, the first command sudo ./configure produces an error:

sudo: ./configure: command not found

So,

  1. I'm wondering if anybody has experienced the same issue and why? Is this common?
  2. Should I expect more issues compiling GnuPG from the binaries?
  3. Any suggestions on alternative PGP command line tools?

I am not interested in the GPGTools/PGP Suite for macOS. I don't want all the bels and whistles. I'm just looking for a command line PGP utility.

Edit: Revised question with Terminal input and output.

  • Are you in the correct directory when running sudo ./configure? Is configure executable? Also, usually the only step which requires sudo is make install, configuring and compiling should work with without. – nohillside Jun 3 '20 at 14:46
  • This edit has significantly changed the issue. What was the ex ct commands you used and what does the re dme say – mmmmmm Jun 3 '20 at 17:17
  • . @timd I don't know how much do the readme & this site macgpg.sourceforge.io/docs/howto-build-gpg-osx.txt.asc differ, but it's a good idea to give it a go. this page points to the former link: gnupg.org/download/supported_systems.html – anki Jun 3 '20 at 17:33
  • @nohillside thanks, i chmod u+x configure and that solved the issue. – TimD Jun 4 '20 at 2:57
  • @ankii I saw that guide when you posted it earlier but it uses gunpg 1.4 – TimD Jun 4 '20 at 13:42
1

The issue command not found occurs because the script ./configure is not executable. I fixed it by setting the executable bit for the user with chmod.

While in the root directory, type the command in Terminal:

chmod u+x configure
  • Interesting. I just downloaded the tar ball from gnupg.org, the extracted configure script is executable. Did you extract the tar ball in a special way (e.g. with sudo)? – nohillside Jun 5 '20 at 14:45
  • I double clicked the archive in Finder but I did that with the ntph binary too – TimD Jun 5 '20 at 14:57
  • 1
    Do you have a special unarchiver installed or are you using the standard Archive Utility? Access rights are set within the tar file already (and there they are correctly set to +x) so I wonder whether an extraction utility does something strange here. – nohillside Jun 5 '20 at 15:59
  • No, default Catalina 10.15.5. I should see if I can replicate the issue tomorrow – TimD Jun 5 '20 at 16:02
  • 2
    Sorry for the late reply. I re-downloaded the tarball and extracted it from Finder. I couldn't reproduce the problem and was able to run ./configure successfully. The only thing I did differently this time was verify the SHA sum. – TimD Jun 7 '20 at 6:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .