0

I'm assuming this USB stick is toast & I'm not going to be doing anything in future with it except for one last short flight into the bin.

The stick gives the "This device is unreadable. Initialise, ignore etc" when inserted. So I go for Initialise which launches Disk Utility, I Erase GUID/HFS+ & this is as far as it gets. I've watched it now for over 4 hours, no change.

enter image description here

Though I could just pull the device out & bin it right now, this doesn't prevent Disk Utility from just sitting there waiting. I tried this yesterday after about half an hour, then thought I ought to reboot because I had to force-quit Disk Utility & wasn't certain what else may be left in an unstable state.

I really assumed it would eventually time out, but it seems not.

To avoid having to reboot, do we know what specific process would be waiting indefinitely? Would it be safe to force-quit? Nothing shows as not responding in Activity Monitor, and Disk Utility doesn't appear to have any child processes, when viewed hierarchically. Nothing is exceptionally busy, everything is currently under 10% CPU, barely ticking over. Disk Utility itself is at 0.0%.

macOS 10.14.6 on a Mac Pro 5,1. Stick tested on USB hub & directly in the Mac, same result. Only this stick is affected.

1

It is failing to write the partition map on the flash-drive (step before formatting the filesystem) in order to do anything with it, so should be in a safe place to force-quit disk utility.

FWIW, it might be worth trying another file-system before you bin it.

  • Hmmm. I force-quit DU, pulled the stick & reinserted - tadahh, it showed up as what it was, a Win boot recovery stick. I ejected & tried again, it's back to unreadable. I've had a poke with DU & Paragon HD Util & mainly it's failed to do anything, so I think that last flight to the bin is in order. I've plenty more & I wouldn't trust it any further anyway. – Tetsujin Jun 2 '20 at 14:48
  • @Tetsujin after that, nor would I – hikerspath Jun 2 '20 at 23:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .