I just completed my first ever Time Machine migration… or I thought I had.

I just got a new 1TB SSD & PCIe mount to lift my speeds up to full SATA III on an old Mac Pro normally limited to SATA II speeds.
I decided now would be time to clean up a bit so I'd do a fresh, clean install then migrate, rather than my usual trick of simply cloning it with Carbon Copy Cloner.

All appeared to go well. Install went smoothly, I was presented with the Migration tool & asked it to migrate from my Time Machine drive [also internal, last updated only 30 minutes prior]. I selected everything - about 500GB, half full drives, old & new.

It busied itself with the copying for a good while, then presented a very long list of esoteric things it couldn't copy - no explanation was given. The list was far too long to give more than a cursory glance to. I thought I could probably get away with missing a few bits, so long as the main stuff had transferred, so I stepped on to the next part of setup, signing into iCloud etc [there was no other choice but to accept the list of fails, it was OK or nothing.]

On finally arriving at the desktop I quickly realised that absolutely nothing had been migrated at all. No Apps, no docs, no music, pictures… zero.

So, I'm currently making a new CCC clone.

Anyone have any idea what may have gone wrong, so much so that absolutely nothing happened after a good half hour of 'being busy'?

Mac Pro 5,1 Mojave 10.14.6 [both old & new installs] 2 x 1TB SSD, 4 other HDs inc one for Time Machine.

Further updates
I've now tried this perhaps 7 times using different strategies. The slimmest version was a brand new Time Machine with a single manual backup, restoring just one account to a wiped SSD. No other drives connected. Both drives on the regular SATA bus, no PCIe card. SIP disabled.
No Joy.
Single file restoration is fine now, though was really broken before I disabled SIP. All apps showed as 'grey with a no-chance sign'.
Migration just will not work, neither will a direct Restore from Time Machine to a blank drive.

  • 1
    I don’t know what happened, but I had a similar experience and after a few attempts and no success, I resorted to Time Machine for backups and dd for imaging. I subsequently threw CCC out the proverbial window. Apple seems most content when you use their tools
    – Allan
    Commented Jun 1, 2020 at 14:34
  • 1
    @Allan - CCC I've never had any problem with. That's what I've ended up doing the swap with. Running from it now, can't tell I ever swapped, except for the slight speed boost on the new PCIe card. I did want to try the 'refresh' of a migrate, as basically I haven't done one ever; this machine is direct line-of-sight right back to my G4 when I first switched to OS X, early 2k's [of course it's a different drive, different machine etc], but I've always just carried the old drive to the new machine & worked from there, CCC as & when the tech gets faster, new drive gets swapped in...
    – Tetsujin
    Commented Jun 1, 2020 at 16:27
  • 1
    Maybe my bad fortune with CCC and I sure wish I could tell you what happened that the migration didn't take.
    – Allan
    Commented Jun 1, 2020 at 18:37
  • 1
    @Allan - if it wasn't for CCC, I'd be dead in the water right now. I must have done this 6 times now, each time I've had to clone back using CCC.
    – Tetsujin
    Commented Jun 20, 2020 at 13:21
  • @Allan: Just curious, what exactly went wrong with CCC? As far as I can tell, the worst that can happen with CCC when a file is corrupt is that you lose exactly one file. Not the whole backup, as can be the case with Time Machine. Commented Jul 27, 2020 at 11:59

1 Answer 1


Here are a few notes which might help you. They wouldn't fit all in a comment, so I took the liberty to write half an answer.


Anyone have any idea what may have gone wrong, so much so that absolutely nothing happened after a good half hour of 'being busy'?

I've had a similar experience almost 10 years ago. From your description, it doesn't seem that Time Machine has changed much since:

  1. Time Machine uses incremental backups in order to save disk space. Files are described by how they have changed over time. In order to restore a file at a given timestamp, diffs are applied on top of each other, starting at the original state of the file.
  2. Time Machine uses hard links for folders, which are not supported by other macOS programs or by Linux.
  3. Time Machine doesn't seem to check the integrity of the backups until they are needed. If any diff, any file or folder gets corrupted, Time Machine does not seem to notice.
  4. During a migration or a recovery, the whole process stops after the first error. One corrupted file seems to be enough to cancel the recovery.
  5. If the recovery process fails, no file gets copied at all, not even the files which have been processed before the first error.

All the above points, together, make for a brittle design. If anything goes wrong, your backup becomes useless, and cannot be read, as is, by any other standard software.

"There's no step 3" doesn't help much when step 1 & 2 fail miserably.


Your data, or at least a part of it, is probably still readable somewhere on your Time Machine drive.

I wrote a script in order to get my data back, but cannot find this script anymore. I remember it used ruby, cp -avX, ditto and chmod in order to parse the data and restore as much as possible.

There are more recent solutions, though. It seems that they use Linux and either bash or python. More info here. One of the scripts, copy_from_time_machine.py seems promising.

Good luck!

  • 1
    to clarify, points 1, 2 & 3 were covered by using a single clean TM run so no hard links, also double-checked with DiskWarrior. Stil 'no werky'.
    – Tetsujin
    Commented Jul 28, 2020 at 9:27
  • @Tetsujin: Thanks for the info. I wouldn't be surprised to learn that hard links are used even for just one single TM, along with the corresponding timestamp. It would be interesting to see how the disk looks like in Linux, for example. I guess other macOS programs are trying to play nice with TM structure or ignore it. Just to be clear, you're trying to use TM for cloning a disk right away? Commented Jul 28, 2020 at 9:36
  • Wipe TM disk, run TM once. Wipe boot disk, set up as new, Migrate when asked. [& at least 7 other variations on that theme] I have all this cloned & backed up elsewhere too, so I'm in no danger of losing data. I just want a 'clean' migrate.
    – Tetsujin
    Commented Jul 28, 2020 at 9:54
  • @Tetsujin: That's sad that TM doesn't manage to do it. It seems like a perfect job for CCC, though, doesn't it? Commented Jul 28, 2020 at 9:57
  • …except just this once, I didn't want a clone. I've been cloning one machine to the next since 2001. Every other Mac in the building also started as a clone of my setup at the time it was installed, then allowed to diverge since.
    – Tetsujin
    Commented Jul 28, 2020 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .