0

I have googled everything, I am desperate. I have installed Catalina yesterday and tried all the steps here (and more) that were logical to me. The thing is I have the feeling the current version has changed again (I read of the stuff you could do to get system read/write on Catalina but nothing works in my case). I have a parallel MacOS / Windows System with a third exFat partition and in Mojave and Lower I always create links for /Applications and /Users to put all non systemrelevant data into the exFat, it always worked fine (though, you have to make some adjustments in order to work with iCloud apps etc). I wanted to do the same, so I followed all the normal steps to create links for /Applications (also tried with /System/Volume/Data/Applications). But it does not work at all. Usually for example I ditto the /Application to the exFat partition and mv the old one into /Application.old (just to be safe), then I create the link. But I cannot rename or delete /Applications! Is it because they created Hard/systemlinks in Catalina?? I don't get it. Will I be able to link out the folders to my exFat partition? Any suggestions?

  • Just a list of things I did: csrutil disable, sudo mount -uw /, sudo mount -uw /System/Volumes/Data, sudo chmod -R 755, sudo mv /Applications /Applications.old, sudo rm -rf /Applications, sudo ln -s /Volumes/SecondaryVolume/Applications /Applications (also tried for /System/Volumes/Data/Applications): The last result is Operation not permitted – BingoBongo May 31 at 9:04
  • If you have another mac, try booting this Catalina mac into target disk mode and edit the links/partitions on the other mac. It may work. – Joy Jin May 31 at 9:29
  • Catalina uses a read-only System partition. No amount of crsutil or sudo chmod will change that. – Tetsujin May 31 at 9:42
  • that is not true Tetsujin, it definitely HAD been possible, as confirmed in many other posts but seemingly Apple has changed the effect of sudo mount -uw / – BingoBongo May 31 at 10:07
  • Yes it is possible somehow. (I was able to do it on catalina with SIP and bunch of other stuff disable/modified) Sadly I can't remember how I managed it. I'm going trough my history and see if I can find anything helpful. – Roxiun May 31 at 10:18

You must log in to answer this question.

Browse other questions tagged .