0

I was using my MBP/Catalina with a logitech mouse and keyboard and the transceiver dongle, plugged into a USB port on a USB-to-Thunderbolt adapter. I wanted to make it ignore the mouse temporarily, so using the Logitech control panel I unpaired the mouse. Unfortunately the trackpad didn't come back, so I had no mouse control at all, even after rebooting.

As recommended here, I managed to reboot in safe mode which gave me the trackpad back, and I ran the Logitech Uninstaller. Rebooted normally, and trackpad worked. However, when I plug the dongle into the USB port, the trackpad stops working.

I tried reinstalling Logitech Unifying Spftware, but it won't proceed until I plug in the dongle, and when I do that, again the trackpad freezes!

Any ideas on solving this?

UPDATE: I confirmed - the trackpad freezes when I insert the transceiver in the USB port, even after I ran the Uninstaller and rebooted. This seems odd - but I don't know enough about USB to know what happens when you plug in something without its control software installed.

Does this sound more like a non-Logitech problem?

UPDATE 2: I discovered that the problem doesn't occur when I log in as my other userid.

UPDATE 3: The System Report/USB page identifies the Logitech receiver when it's plugged in, so it's obviously able to communicate with it.

Now It Works: What I did: switch to my alternate, "clean" user, and installed Logitech Unifying Software there. The mouse worked. Switched to primary user, where I've been having the issue, and installed Logitech Unifying Software there (for like the 4th time). Now the mouse works in the primary user.

  • I use Logitech products almost exclusively and haven’t run into this issue. However, the only variable I’m not familiar with is this “USB to Thunderbolt” adapter. Can you expand on this? Brand, model, etc? – Allan May 31 at 4:16
  • @Allan It's a "Twopan T1-H". It has 4 USB-2?3? ports and an HDMI port. It's plugged into one of the MBP's 4 Thunderbolt ports. I guess it could be USB-C and not Tbolt ?? Edit: I tried another USB/Thunderbolt hub and got the same result. – Chap May 31 at 21:37
  • Never heard of those guys. Try an Anker, they use higher grade components than the off-brands. Oh, and those are USB3 ports – Allan May 31 at 23:33
  • Try resetting SMC or NVRAM/PRAM? – SYGMAH May 31 at 23:47
  • 1
    @Wynter I have reset both SMC and NVRAM, but there's no change. However, I notice that I can login as my other userid and the problem goes away. I will update my question. – Chap Jun 1 at 18:39

You must log in to answer this question.

Browse other questions tagged .