5

I realize a similar question to this has been asked, but it's not the same. The answers in that question are for older versions of MacOS. I'm asking this question specifically for MacOS Catalina 10.15.

2
  • Seems like a pretty tough thing to do without removing Command I functionality completely.
    – Oion Akif
    May 30, 2020 at 20:44
  • I have macOS 10.15.5 (as of last night). In the System Prefs -> Keyboard -> Shortcuts tab, there is no shortcut registered for either of the "New email" options. When I select some text from this page in my browser & use command-i, I get a "page info" window displayed - probably a Firefox shortcut(?). My point being that perhaps you set this - perhaps inadvertently via a mail app?
    – Seamus
    May 31, 2020 at 8:28

4 Answers 4

1

macOS has a built in method for changing/adding keyboard shortcuts

  1. Open System Preferences
  2. Go to Keyboard > Shortcuts > App Shortcuts
  3. Click the "+" button and select Safari from the Application drop down menu
  4. In the Menu Title box enter the EXACT wording of that menu selection "Email This Page" (it must be exact, capitalization, spaces, etc)
  5. Assign a keyboard shortcut you would never use, like Shift-Command-Option-Ctrl-I
  6. Click Add and close system preferences

Note now that the Command-I in that menu has been changed to whatever you set it to, allowing you to set Command-I to something else, or just leaving it that way so you won't accidentally use it.

6
  • It doesn’t seem to be working. Super annoying. It even shows in the safari menu item ‘Email This Page’ as my set command (that I wouldn’t use), yet still when I press Command-I it still composes an email. I made sure to restart and shut off my computer. And closed the apps
    – Andrew
    May 30, 2020 at 21:32
  • Strange, worked fine on my Mac. I did only use COMMAND-OPTION-I... strange. Sry! May 30, 2020 at 22:35
  • 1
    On Mojave - I can confirm that this should work… but doesn't. Both the replacement key command [im my case ti tried a silly cmd/shift/ctrl/opt/F15 as well as the simple cmd/shift/i just to be really sure. Both the replacement and the original still trigger the action. idk why.
    – Tetsujin
    May 31, 2020 at 7:41
  • 1
    I had to relaunch Safari but it does work. Who at Apple thought this would be a nice feature?! 🤦🏼‍♂️ Jan 25, 2021 at 9:47
  • 1
    does not work -- and, even worse in MacOS Ventura, the "Email This Page" and "Email Link to This Page" menu items are simply gone from Safari, but the Cmd-I shortcut STILL opens Mail.app 🤮
    – Bowen
    Sep 27, 2023 at 17:37
0

The only solution that I've found to work for Safari is to change the default mail handler app.

I set mine to Safari itself, which isn't quite perfect but at least it means that Cmd+I (when not trapped by a handler for italics) doesn't open Mail.

As detailed in the top answer of Set default mail client in macOS without adding an email account? you can use SwiftDefaultApps to change the default mail app, as illustrated here ↓

Screen shot of SwiftDefaultApps preferences pane

0

You can remap Command+I to a different action in Safari that is less annoying than composing a new email. For example, I've set mine to open the share sheet which can be easily escaped out of.

Go to System Settings > Keyboard > Keyboard Shortcuts > App Shortcuts and map Command+I in Safari to open "Share...":

system settings

Or you can run the following shell command and then relaunch Safari:

defaults write com.apple.Safari NSUserKeyEquivalents -dict-add 'Share...' '@i'
-1

Add these to your shortcuts, and try restarting your computer. It should work on Catalina.

enter image description here

EDIT: It seems to be a bug that this method won't actually work on Safari, even on macOS 11 (unless they fix the bug before it's officially released).

4
  • It still doesn't work, unfortunately
    – Andrew
    Jun 10, 2020 at 20:17
  • Damn! Did you try restarting? I tried this method and it didn't work immediately, but I noticed after a few days the Command I shortcut went away. Now it shows the above shortcuts in the menu bar. Maybe you need to restart your cache somehow as well after restarting, or potentially reset your safari preferences (when I carried Lightroom preferences over I noticed the custom shortcut was carried along with the .plist file, and it ignored my system preferences setting)
    – Oion Akif
    Jun 10, 2020 at 23:19
  • @Andrew See my updated answer
    – Oion Akif
    Jun 26, 2020 at 23:38
  • 1
    Still with Safari 16 and Mac OS 12.6 these are set, show in the Safari "File > Share" menu with the new shortcuts but still CMD+I is bound. So the bug is still present.
    – Lantrix
    Oct 17, 2022 at 5:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .