2

MacBook Air, 10.13.6 High Sierra.

I tried changing the name of the user on my macbook and accidentally deleted the administrator account. The current user is my user but it says standard under it, there is no admin account on the computer.

I searched on google and I found a solution. Now, when I shutdown and press Command+S a wall of text appears. This text is scrolling so quickly that I can't enter any other command.

Here are the commands I found:

First command: mount -uw /

Second Command: rm /var/db/.applesetupdone

Third Command: reboot

I also found a solution on this site however, I get the same result with the text moving quickly.

Also, I think I need to mention that my Mac has a problem with wi fi and won't connect when it is not logged in.

What can I do to fix this problem?

  • The steps to boot into single user mode has changed somewhat recently, have you taken a look at the Apple Support article on it? – kumowoon1025 May 30 at 11:58
  • Great documentation! I think we can get you the correct steps very quickly to make a new admin account and/or reset the old PW. – bmike May 30 at 14:39
1

The steps you list are for OS older than 10.13. Follow the Apple reset password steps for good results.

Also, I would consider fixing the actual problem. macOS will not let you delete the admin account. You have to have a broken system or run some scripts that could damage anything in addition to the account. Unless you know precisely how you lost your account, it would be better to just back up and reinstall a clean system over top of the existing data and programs.

Same advice when you reset the password, get a backup and be ready to reinstall - perhaps an erase install - your system wasn’t healthy before and getting admin won’t remedy that unhealthy system.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .