1

On macOS Catalina 10.15.4

How do I change the email address used by Calendar to send invitations?

Secondarily, I'd further like to receive acceptances, which don't appear to come.

Context:

  • I have several email adresses.
  • Currently Calendar sends invitations from "My Name <noreply@email.apple.com>".
  • I'd like Calendar to send invitations from my work address.

I've done the following so far:

  • In Mail >> Preferences >> Composing, I changed the Send new messages from: field to my work email.

  • In Contacts >> Preferences >> Template, I have a single email field identified as "work".

  • In Contacts I have moved my "work" email to the top of my emails.

  • In Mail >> Preferences >> Accounts, I attempted to drag my "work" email account to the top of the list of accounts. This does not work in Catalina. You can't change the order of accounts. I understand that one could previously do this.

Nothing works.

Short of deleting the accounts above "work" and recreating them, does any other way exist to do what I need to do?

Why does Calendar send invitations from "My Name <noreply@email.apple.com>"?

This seems weird, but I may have missed something.

Any help appreciated.

  • Doesn't Calendar.app use signed in iCloud account email address? – Steve Chambers May 31 at 16:22
1

Standard way:

Go into Mail preference with

Mail > Preferences > Composing

and then change the following option: “Send new messages from”

If this did not work:

Go into Contacts and create a new card or pick the one with the mail address you want to use (i.e. your work e-mail).

Afterwards, go to the Card menu and select “Make this My Card”. This mail address should now be your default for Calendar.

| improve this answer | |
  • Your second way got me on the right track, but I had to recreate my Card and delete my previous one to get it to work. – Jagra Jun 1 at 14:30
  • One odd thing. The invitation includes a message starting with my email address, which I have everywhere on my machine in lower caps, but the invite message seems to randomly capitalize some of the letters. Not the end of the world, but it just does not look professional. Thoughts? – Jagra Jun 1 at 14:34
  • @Jagra Yeah, that seems annoying. Sadly, I can't test it myself in order to figure something out as I no longer have a MacOS install available. I just knew the Contacts trick from back in the day :/ – hlzl Jun 2 at 14:13
0

GoDaddy, the host of my work email, has advised me that no way exists to do this currently in Apple's Calendar application.

| improve this answer | |
  • See selected answer above. It appears GoDaddy has incorrect information. – Jagra Jun 1 at 14:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .