2

I am trying to upgrade a 2012 Mac Pro (model 5,1) to Mojave. I have installed High Sierra and updated bootrom to MP51.0089.B00. I've got a required "metal capable" graphics card (Sapphire PULSE Radeon RX580), which unfortunately does not support the Startup Manager. I want access to the Startup Manager, to be able to access recovery partitions and bootable external media.

My plan: rEFInd seems like a good solution to my problem. Before installing the unsupported GPU, if I can get rEFInd to appear as an option in the Startup Manager, I can select it as the default using the control key when selecting the boot option (this does work on my machine). Then once I install the unsupported GPU, the rEFInd main screen will appear on startup and I can select whatever I want, including recovery partitions and external media. (Obviously I must be careful never to change the default in SystemPrefs->StartupDisk, or I'll have to temporarily re-install the old GPU and change the default back to rEFInd !). Does this sound like a workable plan ?

I've installed rEFInd, with default options, and it does not appear in Startup Manager. To get it to appear in Startup Manager, I believe I need to reinstall it with the --usedefault option. How do I reinstall ? Do I need to uninstall first (since I first installed it without the usedefault option) ? Uninstalling looks somewhat problematic. And what argument do I need to use with --usedefault ? I've looked at a wiki and a manpage, but am still confused. When I ran 'mountesp', I got:

sudo mountesp
The ESP has been identified as /dev/disk0s1; attempting to mount it....
The ESP is mounted at /Volumes/ESP

The only file in that volume is: /Volumes/ESP/EFI/APPLE/EXTENSIONS/Firmware.scap

That's it. I am out of my depth, and would appreciate help.

  • You can temproarily access macOS Recovery by using Command + R which doesn't have anything to do with Startup Manager. You can then use the Startup Disk option to select which disk you would like. Let me know if this helps. – Todd May 29 at 20:36
  • I tried Command+R with the unsupported GPU (the "metal" one needed for Mojave) and the screen stayed black. – RustyShackleford May 29 at 20:44
3

Removing rEFInd from the EFI partition.

If you use refind-install without any options and/or the --usedefault option to install rEFInd into the EFI partition (disk0s1), then use the following steps to remove rEFInd from this partition.

  1. Make sure the EFI partition (disk0s1) is unmounted. Use the command given below.

    diskutil unmount disk0s1
    
  2. Mount the EFI partition (disk0s1). The command is given below.

    sudo diskutil mount disk0s1
    
  3. Use the Finder to open the EFI folder on the EFI volume.

  4. If any of the following folders exist in the EFI folder, then move each folder to the trash: BOOT, refind and tools

    In other words, if the any of the following folders exist, then the folder should be removed.

    /Volumes/EFI/EFI/BOOT
    /Volumes/EFI/EFI/refind
    /Volumes/EFI/EFI/tools
    
  5. Empty the trash.

  6. Use the command given below to unmount the EFI partition.

    diskutil unmount disk0s1
    

Installing rEFInd to appear in the Mac Startup Manager

Note: If rEFInd already exists in the EFI partition (disk0s1), then the instructions given in this section may fail. You should make sure rEFInd is removed from the EFI partition (disk0s1) before proceeding.

The commands to install the current version of rEFInd is given below. You should enter these commands from macOS.

sudo $HOME/Downloads/refind-bin-0.12.0/refind-install --usedefault /dev/disk0s1
diskutil unmount disk0s1

Below is the output when the above commands were entered using the current version of Catalina (macOS 10.13.6).

Note: When testing, I received the error message sed: -i may not be used with stdin. This error did not effect the installation of rEFInd other than not unmounting disk0s1

The rEFInd Boot Manager should now appear in the Mac Startup Manager with the label EFI Boot. Both the icon and label can be customized.

| improve this answer | |
  • Thanks. So no need to un-install what I've already done (when I used the install script with no options) ? – RustyShackleford May 29 at 21:57
  • It complained that the /dev/disk0s1 "resource was busy" so I rebooted into the OSX that was not on the partition where /dev/disk0s1 is. And then the install seemed to work, until "Could not set boot device property: 0xe00002bc". Also complained that refind.conf already existed so it coulnd't copy the sample one to it; I assume that doesn't matter, since I never edited it, unless using --usedefault in the install makes the sample one different somehow. – RustyShackleford May 30 at 0:48
  • Anyhow, it didn't work; rEFInd does not appear in the Startup Manager. – RustyShackleford May 30 at 0:49
  • Seems like it ("Could not set boot device property") could be because of SIP. I see instructions elsewhere for disabling SIP temporarily (booting into recovery mode) but also that it should no longer be necessary. – RustyShackleford May 30 at 1:30
  • 1
    Ok, I posted a question here. I used superuser because @RodSmith has never answered a question here at Ask Different. – David Anderson May 31 at 20:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .