1

my external hard drive worked fine last week. I cannot get it to mount or show up. here is what it looks like, and here is what i have tried.

enter image description here

First aid does nothing, mount does nothing.

I have tried this in terminal:

mount -t /dev/disk2
mount force -t /dev/disk2
diskutil verifyDisk /dev/disk2
diskutil repairDisk /dev/disk2
diskutil repairDisk /dev/disk2

and got back this:

Jennas-MacBook-Pro:~ jmeacham$ diskutil verifyDisk /dev/disk2
Started partition map verification on disk2
Checking prerequisites
Checking the partition list
Checking the partition map size
Checking for an EFI system partition
Checking the EFI system partition's size
Checking the EFI system partition's file system
[ / 0%..10%..20%......................................... ] diskutil repairDisk /dev/disk2
Checking the EFI system partition's folder content
Checking all HFS data partition loader spaces
Checking booter partitions
Checking Core Storage Physical Volume partitions
The partition map appears to be OK
Finished partition map verification on disk2
Jennas-MacBook-Pro:~ jmeacham$ diskutil repairDisk /dev/disk2
Repairing the partition map might erase disk2s1, proceed? (y/N)

I said NO because i cannot lose what is on this hard drive.
I am NOT very computer literate, so honestly don't really know what the terminal message means, i just know i can't risk loss if I don't know what will happen.
If anyone has any ideas please let me know. Also if you could be as detailed as possible in instruction because like I said I am kinda dumb about computers. Thank you so much for any help.

3
  • Also, I feel like this is a common problem for me. I often have trouble with hard drives not showing up.. is there something I am doing wrong? is it the computer or the hard drive? kind of an after thought, but it gets frustrating.
    – jenna
    May 29 '20 at 18:08
  • While I can't speak to why this is a common problem for you, this IS an HFS+ disk and might yield to a 3rd party disk repair utility like Diskwarrior. May 29 '20 at 18:55
  • The mount commands didn't work for you because they are malformed. What you have after the -t option is not what's expected. You can read the manual page for mount in Terminal by typing mount and then right-click on it and select: Open man Page May 29 '20 at 22:14
1

There is an app called Mountain that will mount and unmount your drives. It works well on my iMac. There is a free trial version on their website. You might give this a try. Its mounted problem disks for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .