I'm using a 2003-era external iSight "Autofocus Video Camera + Noise Suppression Microphone" with an Apple Cinema Display and USB-C MacBook Pro running macOS 10.15.

It's connected via a long succession of dongles:

iSight > FireWire 400 > Apple Cinema Display > FireWire 800 > Thunderbolt 2 > Thunderbolt 3

It still works great for video, if a bit low resolution, and you can't beat the design:

external iSight camera

However, the iSight camera's microphone does not appear to be working. People cannot hear me when my laptop is in clamshell mode, despite being on video via the external iSight.

In System Preferences > Sound > Input I only see "MacBook Pro Microphone":

Sound Input

System Information shows a FireWire iSight device, as well as an "Unknown Device". When I unplug the FireWire cable/dongle, both devices disappear.

System Information

This iSight is running the 1.0.2 firmware; I'll try to update it with 1.0.3 and test:

Why isn't the iSight mic working? How can I use an external iSight as an audio/video webcam in modern versions of macOS?

Related threads that seem to be experiencing the same issue:

  • Have you tried the iSight connected to another Mac not running Catalina? May 28, 2020 at 22:36

3 Answers 3


The FireWire iSight audio driver has been omitted from recent macOS releases.

A Mac Rumors contributor has posted a download of the driver from his backup.

Download iSightAudio.driver there, or find the same driver from your own pre-Catalina backup.

Place the file in /Library/Audio/Plug-Ins/HAL/

I used a copy from a backup of OS X 10.13. A Finder copy and authentication worked without any permissions issues.

This worked for me on Catalina 10.15.6 on a 4,1->5,1 cMP.

  • This worked for me on Catalina. After installing iSightAudio.driver and restarting, the external iSight's microphone is shown in System Preferences > Sound > Input.
    – pkamb
    Feb 1, 2021 at 4:20

Everything points to the microphone (audio circuitry) having died.

It's a man-made device and they fail. What you're seeing is that the device itself is being recognized on the Firewire bus, but that does not mean that the end components (microphone, camera, etc.) are functional.

Unfortunately, it's time to retire it and get a new one.

  • I've now tried 2 external iSight cameras. Both work for video; neither for audio. I believe this is a driver/software issue and not hardware failure.
    – pkamb
    Jun 1, 2020 at 18:53
  • that's entirely possible as well. It's an old device and Apple may have just pulled the support for it. To verify it's not a conflict with a 3rd party device driver, boot into Safe Mode (Hold Shift while booting) and try the camera. If it works, something you've loaded is causing the issue. If not, the OS is no longer supporting it.
    – Allan
    Jun 1, 2020 at 18:59

I have the exact same problem and age is not the issue. Apple posted an update to Catalina [10.15.4] which repairs this OS issue unless your are already using [10.15.5] or [10.15.6] therefore I am not be able to install the 10.15.4 Supplemental content called [macOSUpd10.15.4Supplemental.dmg]. For those whom have not updated past 10.15.4 as yet, go here to find the file.


  • How do you know what 10.15.4 fixed this iSight issue? Are there any patch notes that indicate this?
    – pkamb
    Sep 3, 2020 at 13:00
  • I spoke to Apple today and they claimed that there is no evidence that 10.15.4 Supplemental worked and of course, the camera is too old to receive technical support. He read several Apple articles and claims that his only recommendation was to take the computer and camera to an Apple Authorized Dealer. Elsewhere I read that someone installed the 10.15.4 upgrade and supplement and it did not solve the problem. The microphone still could not be recognized by the system. You don't become a $2 Trillion dollar company by fixing old equipment issues!
    – ASLA
    Sep 5, 2020 at 5:01
  • Check the Answer above... you need to instal an iSight driver from an older version of OS X.
    – pkamb
    Feb 17, 2021 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .