1

Since I use Catalina my Mail notification sounds don't work properly. They sound minutes or even hours after the new mail arrives. Sometimes the sound rings at the moment I switch to an open window in Safari. Or back to Mail coming from Safari. The issue appeared with the first release of Catalina, but is still there after several updates and a complete re-install (from the internet).

I'm on Catalina 10.15.5 on a MacBook Pro 13" late 2013. I just have one Mail account active.

  • It’s definitely not a PowerBook. Do you mean MacBook Pro or Air? Those are the only two models of laptop that had releases in 2013. When you did a clean re-install, did you wipe the drive first? Can you try this in Safe Mode” – Allan May 28 at 14:04
  • Sorry, shure it's a MacBook Pro. I had so many Apple laptops in my life, can't keep up with the name changes. I did not do a 'clean' re-install. It would take me days to get everything in place again. Just re-installed the system, with the Apple apps. – DeNeve May 28 at 14:19
  • Ok. Try safe mode. Second, before wiping your drive, try installing on an external USB flash or drive (need 32 GB or more; it only for testing). Boot off that drive and try Mail. If the problem goes away, the issue is with your OS – Allan May 28 at 14:30
  • Seems a bit of a hastle, where it in fact is already clear that the problem is with my OS. The question is: how to fix it? – DeNeve May 30 at 7:19
  • I font know how to fix a problem that we haven’t identified the cause of. – Allan May 30 at 13:14

You must log in to answer this question.

Browse other questions tagged .