0

I am experimenting with moving Documents and Desktop into iCloud Drive. I have a website document root in a folder under Documents. For the website to run on my local machine the permissions of ~/Documents folder must be 755.

As soon as I change a file in the website, the permissions on ~/Documents immediately changes from 755 to 700, causing the website to give a "Forbidden" message.

I am guessing that the iCloud sync function is resetting the permission of ~/Documents. How do i prevent this from happening?

I have tried "chflags uchg Documents", but it still resets to 700.

1

I had the same problem, trying to run a server as an unprivileged user that needs read access to Documents, while Documents is in iCloud Drive. Normal UNIX file permissions didn't stick. I solved it by using ACLs to grant access.

chmod +a "_www allow list,search" Documents

In this example _www is the unprivileged user your server is running as. Use ps axu to find out what user that is for you.

The folders inside Documents should work like normal with UNIX file permission bits, so you only have to do this for the Documents folder itself.

For more info on ACLs, see here here and man chmod.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .