0

I have 30gb of free disk space on 250gb disk which should be more than enough

I cannot install 10.15.5 it just restart and still says I haven’t installed

Update

Just now it wasn't showing the purgeable but now it is after my successful update.

enter image description here

6
  • 1
    See apple.stackexchange.com/a/370809/85275 for how to check actual free space vs purgeable.
    – Tetsujin
    May 27, 2020 at 12:36
  • Mine doesnt show purgaeable
    – Kim Stacks
    May 27, 2020 at 12:58
  • So what does it show? Please add the necessary information to your original question.
    – Tetsujin
    May 27, 2020 at 13:00
  • 1
    Have you tried restarting, holding down option-command-R and using Internet Recovery mode to upgrade your OS?
    – da4
    May 27, 2020 at 13:23
  • Sorry am on phone and I tried something different before I update the question @Tetsujin now the laptop entered into update mode successfully I think
    – Kim Stacks
    May 27, 2020 at 13:25

2 Answers 2

1
  1. Update the xcode to the latest version (I had to try this twice)
  2. Restart
  3. Try again to update to 10.15.5

This time it worked

0

I had a similar issue and discovered that the problem was down to disk space. After various fruitless attempts at restarting and hoping for the install to happen, I decided to try installing manually and downloaded the update. I ran the installer and got an error message telling me I didn't have enough disk space. This was odd as I had about 15Gb, which I thought would be enough.

After clearing out some old files I eventually got to 28Gb free and tried to install the update again. It still failed with the message that there wasn't enough disk space. Using the DaisyDisk utility I looked at how much disk space I had and noticed that of the 28Gb that was free, only 10Gb was really free and the other 18Gb was purgeable. My guess is that the Installer program only checks truly free space and given that the actual update itself is around 9Gb, it probably decided that there wasn't enough space to do an install.

So I used the DaisyDisk utility to do a proper purge of the purgeable space i.e. truly cleaning the files in it off the disk. I now had 28Gb of genuine free space and the install proceeded without a hitch. If the install keeps failing using the Software Update approach, it may be an idea to try a manual install as that seems to at least give you an error message to work with.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .