1

I am using my free Apple developer account (Apple ID) for learning to develop iOS apps with Xcode. My iOS version is 13.5 and I am running Xcode 11.5 on Mac Catalina version 10.15.4.

I created a simple app that prints some text on the screen on my iPhone X, and when I tried to run the app, Xcode returned an error:

"Unable to install app", error code: -402620383.

When I clicked for more details, I got a more detailed description of the error:

"The maximum number of apps for free development profiles has been reached."

After much search on the Internet, I tried the following fixes and none of these worked:

  1. Creating a new Apple ID and link that to Xcode.

  2. Unpaired my iPhone X/deleted the provisioning profiles in windows/devices in Xcode.

  3. Checked in the windows/devices and simulators and there were no apps installed.

The interesting thing is that I tried running the app on my wife's iPhone X (running iOS 13.5 as well) and it worked. Digging a little deeper, I noticed device management under settings/general is missing in my iPhone but present in my wife's iPhone. The profile of the app I was trying to install in device management. Maybe that is the cause of the problem. I really don't know what to do and would appreciate help on this, thanks!

  • What worked for me was deleting and reinstalling Xcode. – Todd May 26 at 3:11
  • @Todd That's not the approach to take in my opinion. It isn't reasonable to reinstall Xcode entirely just to switch to a different developer account/device. – Nimesh Neema May 26 at 10:06
  • Do you have other apps that are already installed using this method? Or does this happen the first time you try? – Tom Harrington May 26 at 17:01
  • @Tom Harrington I had no previously installed apps, it's my first time testing the app on my iPhone. What I don't understand is the app worked fine on my wife's iPhone running the same version of iOS but it didn't work on my phone. – JohnC May 27 at 0:03
  • 1
    I found the solution. It seems that the free developer account is counting 'offloaded' apps toward three apps limit. stackoverflow.com/questions/61953293/… – JohnC May 28 at 8:47
0

Delete the DerivedData folder in Terminal:

rm -rf ~/Library/Developer/Xcode/DerivedData

If it still doesn't work, reinstall the Xcode (it's an issue in Catalina).

| improve this answer | |
0

It is a very hot issue with the new update of Catalina. To be very precise the issue is with the manually signing of the provisioning profile. If you check Automatically manage signing it works.

| improve this answer | |
0

Free developers, head to stack overflow for instructions how to delete your old apps to get back under the limit.

Or if your pay for a dev subscription, this limit is eased and you can work work developer support if needed.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged .