I received a broken 2017 MacBook Pro from a friend who had given up on it. On attempting to boot it up I saw the "no entry" sign, which as far as I understand means there's something wrong/corrupted in the hard drive. I managed to get to the internet recovery screen and attempted to reinstall the OS but couldn't. Running First Aid showed that the APFS file was corrupted in a way that I couldn't fix. I tried to delete the file and replace it with a new one and that didn't work either. For reference, I'm a software developer but I don't understand much about BIOS and such things, especially on Apple computers which I never use.

After a few deletion attempts, or maybe a successful one, I don't remember, I became unable to reach the recovery menu again. The Apple logo would appear with the loading bar, and the bar would fill a tiny amount over 10 seconds or so before I was sent to the black screen with the no entry sign again.

Due to my hacking (I'm guessing) I can no longer seem to access the Internet Recovery menu. Does anyone know a solution to this problem? I thought of maybe trying to boot from a Linux disk or USB or opening up the laptop and physically replacing the hard drive. Would either of these work?

  • The prohibitory sign means your Mac can’t find a bootable volume. Boot Internet Recovery, use Disk Utility to wipe the drive, the reinstall macOS.
    – Allan
    Commented May 26, 2020 at 1:11

3 Answers 3


Why not install a fresh copy of macOS on an external drive before you make any changes to the internal drive. This Mac supports internet recovery so you can boot to internet OS - use Disk Utility to erase / prepare the external drive (USB or Thunderbolt is fine) and then download the installer from the internet while in recovery boot.

Now you can boot to the external drive and make sure the system is healthy and see if you can wipe the internal or need a repair.

If you have nothing to lose on the Mac, follow Allan’s excellent answer for how to erase and install without pausing to work on an external drive.


The "prohibitory or no entry sign" means that it cannot find a bootable volume. It could be from corruption where a few files got messed up or it could simply be missing.

You've done a lot of hacking away at the system and it's difficult to know exactly what's left so your best bet is just to wipe things clean and start with a fresh install. However, before proceeding, there's a few things to clear up...

  • There's no APFS "file." You have APFS container(s) on your drive and within those containers you can have different volumes. One of those volumes is the boot volume from which your Mac reads to start loading the OS.

  • The 2017 MacBook Pro doesn't have a removable hard drive, so there's no swapping it out.

  • Booting Linux or a USB (with what OS?) isn't going to fix a missing/corrupt boot loader. It has to be reinstalled.

Reinsalling macOS

  1. Start in Internet Recovery Mode Hold Option-Command-R and wait until the installer appears

  2. Select Disk Utility from the Tools Menu. When it loads, erase the internal drive and format using the APFS file system. When finished, quit Disk Utility (don't reboot. You'll return to the "main menu."

  3. Select "Reinstall macOS." This will install a clean copy of macOS onto your system complete with boot loader. Once finished, it will be able to boot again.

Please note that the above instructions are simplified for this post. If you have data to backup, that should be done first.

  • Hey, I really appreciate your help! To clarify, as of my latest hacking attempt I am no longer able to access Internet Recovery Mode. Am I stuck? Is there a way to boot from an external drive without reaching recovery mode? Commented May 26, 2020 at 20:22
  • Oh man...If I were to get paid for typos today, I could retire. It's Option-Command-R not Shift. Give that a shot and you should be able to get Internet Recovery going. Sorry for the mistake
    – Allan
    Commented May 26, 2020 at 20:42
  • If i were to get paid for writing intelligible StackExchange posts, I could retire... I've tried both option-command-R and command-R, both of which worked previously and let me access Internet Recovery Mode. However, they no longer seem to work. Also, I tried to reinstall macOS a bunch of times when I was in recovery mode and it ran into an unspecified error, all I got was "exit code 8" Commented May 26, 2020 at 20:50
  • Add the Option key to the key combo so it's Option-Command-R This will install the latest version that's compatible with your Mac. The "Exit Code 8" is a file system error. Were you able to get into Disk Utility? Can you take a photo of what you're seeing?
    – Allan
    Commented May 26, 2020 at 21:06
  • Also, I created a chat room so we we can work in more real time and not fill up the comments: chat.stackexchange.com/rooms/108519/…
    – Allan
    Commented May 26, 2020 at 21:11

I can't speak to the "no entry" sign, but if you have any friends or colleagues that use an Apple desktop/notebook, with their help I would create a bootable USB stick using the most recent OS that the Macbook Pro supports, which I think is Catalina since it's a 2017, and try to perform a clean install of the O.S. using the USB stick. Details on how to create a USB Bootable disk are here: https://support.apple.com/sl-si/HT201372

Also, another option is to make an appointment at an Apple store, if you have one in your area, to see if one of their support reps could help you get the machine running.

  • How does one create a bootable installer if this is the only Apple the OP has since he states "...Apple computers which I never use?"
    – Allan
    Commented May 26, 2020 at 2:04
  • @Allan My hope is that through the help of friends/colleagues who may have an Apple computer, he may be able to create one. Since he is new to the platform, I wanted to give another solution he could try that hasn't been stated yet. Also, he may be able to try visiting an Apple store and see if they could help him out.
    – Anil
    Commented May 26, 2020 at 2:07
  • 1
    It's helpful to include those details because, as the OP states, they're not familiar with Apple.
    – Allan
    Commented May 26, 2020 at 2:10
  • Thank you for the advice @Allan, I will amend my post.
    – Anil
    Commented May 26, 2020 at 2:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .